summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Pompili2015-09-27 16:33:20 +0200
committerMarco Pompili2015-09-28 12:11:05 +0200
commit004d2f099ad85497b040083b6e8b5815495d97a7 (patch)
treefc1e28a22f9fa6a1905ce2e23186b4d6d6260db6 /PKGBUILD
downloadaur-004d2f099ad85497b040083b6e8b5815495d97a7.tar.gz
Initial version 0.8.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faa2d12057a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=openframeworks
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="openFrameworks is an open source C++ toolkit for creative coding."
+url="http://openframeworks.cc/"
+arch=('x86_64' 'i686')
+license='MIT'
+depends=('cairo' 'mpg123' 'gst-plugins-ugly' 'freeimage' 'gst-libav' 'python-lxml')
+optdepends=('codeblocks' 'xterm')
+makedepends=()
+install=openframeworks.install
+
+[[ "$CARCH" == "i686" ]] && _arch="linux" || _arch="linux64"
+_name=of_v${pkgver}_${_arch}_release
+
+source=("http://www.openframeworks.cc/versions/v${pkgver}/${_name}.tar.gz" "of-make-workspace")
+
+[[ "$CARCH" == "i686" ]] && md5sums=("ff38e469b8ebda0529c9d131bc4f499c") || md5sums=("8465ecdaf86a45f0e0f43443e98966fe")
+
+md5sums+=("6a6111a7a98279498899ef0eba789589")
+
+build() {
+ cd ${srcdir}/$_name/scripts/linux/
+
+ msg2 "Building openFrameworks..."
+ ./compileOF.sh > /dev/null
+
+ msg2 "Building the OF Project Generator..."
+ ./compilePG.sh > /dev/null
+}
+
+package() {
+ install -d -m755 "${pkgdir}/opt"
+
+ cp -R "${srcdir}/${_name}" "${pkgdir}/opt/openFrameworks"
+
+ install -D -m775 "${srcdir}/of-make-workspace" "${pkgdir}/usr/bin/of-make-workspace"
+
+ msg2 "Fixing emptyExample project files permissions..."
+
+ chmod 644 "${pkgdir}"/opt/openFrameworks/apps/myApps/emptyExample/config.make
+ chmod 644 "${pkgdir}"/opt/openFrameworks/apps/myApps/emptyExample/emptyExample.cbp
+ chmod 644 "${pkgdir}"/opt/openFrameworks/apps/myApps/emptyExample/emptyExample.workspace
+ chmod 644 "${pkgdir}"/opt/openFrameworks/apps/myApps/emptyExample/Makefile
+}