summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Pompili2020-01-01 13:56:54 +0100
committerMarco Pompili2020-01-01 13:56:54 +0100
commit5be4030fe7fdf520bc35806292a589189751197b (patch)
tree3ed6473aaf5a33e08a300c39dac208686565d2cd /PKGBUILD
parentff2c6982670e6f378d021f26f4adbdd3578aa8d8 (diff)
downloadaur-5be4030fe7fdf520bc35806292a589189751197b.tar.gz
Version 0.11.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2b3c1c8627f..758ef53599ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,38 @@
-# Maintainer: Marco Pompili <aur (at) mg.odd.red>
+# Maintainer: Marco Pompili <aur@mg.odd.red>
DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
pkgname=openframeworks
-pkgver=0.10.1
-pkgrel=3
+pkgver=0.11.0
+pkgrel=1
pkgdesc="An open source C++ toolkit for creative coding."
url="http://openframeworks.cc/"
arch=('x86_64')
license=('MIT')
-depends=('make' 'pkg-config' 'gcc' 'openal' 'python-lxml' 'glew' 'glfw-x11' 'pugixml' 'freeglut' 'freeimage' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'opencv' 'libxcursor' 'assimp' 'boost' 'mpg123' 'rtaudio' 'uriparser')
+depends=('make' 'pkgconf' 'gcc' 'poco' 'openal' 'python-lxml' 'glew' 'glfw-x11' 'pugixml' 'freeglut' 'freeimage' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'opencv' 'libxcursor' 'assimp' 'boost' 'mpg123' 'rtaudio' 'uriparser')
optdepends=('qtcreator' 'xterm')
options=(!strip)
install=openframeworks.install
source=(
- "glew_fix.patch"
+ "openal_fix.patch"
"of-make-workspace"
"https://openframeworks.cc/versions/v${pkgver}/of_v${pkgver}_linux64gcc6_release.tar.gz")
-sha256sums=('1c36ee2b8d931c4450e7113324a58a63222465f9469e6732419616de803cddcc'
+sha256sums=('3e04a8ff4da53e813c0d20b87d5f2231a10767b3a0960af46b0902812b616734'
'b4fc38288595df566f770018d871970fb13fb2ad4af7e9e5cddc60288f338806'
- '9cc5133028b84d5031dbd054719238095e46a5aed507f3b32265fa2906f37905')
+ '513cee3ce081e79fdc1a942af09869145fff3d7addeee0a76cef26fbc3ae69b1')
_name="of_v${pkgver}_linux64gcc6_release"
prepare() {
cd ${srcdir}
- msg2 "Applying fix for glew redeclaration"
+ msg2 "Applying patch for openAL..."
# copy patch
- cp glew_fix.patch ${_name}
-
+ cp openal_fix.patch ${_name}
+
# apply patch
cd ${_name}
- patch -p0 < glew_fix.patch
-
-
+ patch -p0 < openal_fix.patch
export OF_ROOT=${srcdir}/${_name}
export LC_ALL=C
@@ -72,7 +70,7 @@ build() {
make -j$cores Debug
msg2 "Building openFrameworks Release version"
- make -j$cores Release
+ make -j$cores_JOBS Release
cd ${srcdir}/${_name}