summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2021-11-14 17:57:54 -0300
committerTércio Martins2021-11-14 17:57:54 -0300
commit442298f021ae1b05931564b546d524d492704d43 (patch)
tree2f1a44cfe0aae8728710e6271edab2b529ca9b9b /PKGBUILD
parent17d97c5fec2faaf7ba8204c4b01e9a540a54eb87 (diff)
downloadaur-442298f021ae1b05931564b546d524d492704d43.tar.gz
Fixes to compile with dependency "opencolorio1"
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 982d6af44b26..8552e868b93b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,7 @@
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-io-git
-pkgver=Natron.2.4.0.r0.g47c236e
-_pkgname="${pkgname}-Natron-${pkgver}"
+pkgver=Natron.2.4.1.r1.g7714dd5
pkgrel=1
arch=('x86_64')
pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
@@ -28,6 +27,11 @@ sha512sums=('SKIP'
'SKIP'
'SKIP')
+pkgver() {
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd ${_pkgname}
git submodule init
@@ -40,6 +44,11 @@ prepare() {
git submodule init
git config submodule.tinydir.url ${srcdir}/tinydir
git submodule update
+ cd ../..
+
+ # Change OpenColorIO library references to the version of "opencolorio1" package
+ find IOSupport/ -name GenericOCIO.* \
+ -exec sed -i 's/include <OpenColorIO/include <OpenColorIO1/' {} \;
}
build() {