summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2023-01-21 16:19:57 +0100
committerChristopher Reimer2023-01-21 16:19:57 +0100
commit5581c2ae2d698d46cc9f0cfa4d3763e532305cfc (patch)
tree729f34e31fa73540e110672849074ed744df05be /PKGBUILD
parentdee749d1932a7bd75da655740cdeafb84489034e (diff)
downloadaur-5581c2ae2d698d46cc9f0cfa4d3763e532305cfc.tar.gz
Update opengothic 0.64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 39 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f60b5352e1ad..7f658ae4a4b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,64 @@
# Maintainer: Christopher Reimer <mail at c-reimer dot de>
pkgname=opengothic
-pkgver=0.63
+pkgver=0.64
pkgrel=1
pkgdesc="Open source remake of Gothic 2: Night of the raven"
arch=('x86_64')
url='https://github.com/Try/OpenGothic'
license=('MIT')
-depends=('alsa-lib' 'gcc-libs' 'libx11' 'vulkan-icd-loader' 'bullet' 'physfs')
+depends=('alsa-lib' 'gcc-libs' 'libx11' 'libxcursor' 'vulkan-icd-loader' 'spirv-cross')
makedepends=('cmake' 'git' 'glslang' 'libglvnd' 'vulkan-headers')
-source=("git+https://github.com/Try/OpenGothic#commit=15d89bca24c04bfdf287d9b5ec12a65c9cb69a49" #tag=v0.63
- "git+https://github.com/Try/Tempest.git#commit=827449a81776ecfc8e6b34314abf5d5eb9b5134b"
- "git+https://github.com/schellingb/TinySoundFont.git#commit=d4ffcdc8a34d3f61f22e4b283b4c100f5adf4b82"
- "git+https://github.com/Try/ZenLib.git#commit=65b2c1f34e3d3dcd4dd6e6e1c9526996f76e0fe3"
- "bullet_dynamic.diff"
- "zenlib_dynamic_physfs.diff"
+source=("git+https://github.com/Try/OpenGothic#commit=588f099119e6b8ed30ff3f18328de81df887af24" #tag=v0.64
+ "git+https://github.com/Try/Tempest.git"
+ "git+https://github.com/schellingb/TinySoundFont.git"
+ "git+https://github.com/bulletphysics/bullet3.git"
+ "git+https://github.com/lmichaelis/phoenix.git"
+ "git+https://github.com/doctest/doctest.git"
+ "git+https://github.com/g-truc/glm.git"
+ "git+https://github.com/foonathan/lexy.git"
+ "git+https://github.com/lmichaelis/phoenix-libsquish.git"
+ "git+https://github.com/mandreyel/mio.git"
)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '5aa822c283aefa0da9c75ae87e37ec66d50e71f65191187bb15e48a43fb6ea713278dd4a056e9ad04a25a622cdd85834ba5e2c4bf60bd178a46ce4eaba082981'
- '331db32a87762503d4b6abda25369497e8e8660ea381b4363a7a6fccda65d4b1595f83fb27e05f368a943b2b00968ecb5ae8f2323a40ac85f37d68ed4bb172d0')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
options=('!emptydirs')
prepare() {
- cd "${srcdir}/ZenLib"
- patch -p1 -i "$srcdir/zenlib_dynamic_physfs.diff"
-
cd "${srcdir}/OpenGothic"
- patch -p1 -i "$srcdir/bullet_dynamic.diff"
- rmdir lib/ZenLib
- ln -sf "$srcdir"/ZenLib/ lib/ZenLib
-
- rmdir lib/Tempest
- ln -sf "$srcdir"/Tempest lib/Tempest
+ git submodule init
+ git config submodule.lib/Tempest.url "$srcdir/Tempest"
+ git config submodule.lib/bullet3.url "$srcdir/bullet3"
+ git config submodule.lib/TinySoundFont.url "$srcdir/TinySoundFont"
+ git config submodule.lib/phoenix.url "$srcdir/phoenix"
+ git -c protocol.file.allow=always submodule update
- rmdir lib/TinySoundFont
- ln -sf "$srcdir"/TinySoundFont lib/TinySoundFont
+ cd "${srcdir}/OpenGothic/lib/phoenix"
+ git submodule init
+ git config submodule.vendor/doctest.url "$srcdir/doctest"
+ git config submodule.vendor/mio.url "$srcdir/mio"
+ git config submodule.vendor/lexy.url "$srcdir/lexy"
+ git config submodule.vendor/libsquish.url "$srcdir/phoenix-libsquish"
+ git config submodule.vendor/glm.url "$srcdir/glm"
+ git -c protocol.file.allow=always submodule update
}
build() {
cd "OpenGothic"
+
cmake -B build \
- -DBUILD_SHARED_LIBS=ON \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ -DBUILD_SHARED_LIBS=OFF \
+ -DTEMPEST_BUILD_SHARED=OFF \
-DCMAKE_BUILD_TYPE=None \
- -DOpenGL_GL_PREFERENCE='GLVND' \
- -DPHYSFS_BUILD_SHARED='OFF' \
-DCMAKE_INSTALL_PREFIX=/usr \
-DSPIRV_CROSS_STATIC=OFF \
-DSPIRV_CROSS_SHARED=OFF \
@@ -57,6 +69,9 @@ build() {
package() {
cd "OpenGothic"
DESTDIR="${pkgdir}" make -C build install
+ rm -r "${pkgdir}/usr/lib"
+ rm -r "${pkgdir}/usr/include"
+
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}