summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2021-02-14 21:08:00 +0100
committerChristopher Reimer2021-02-14 21:08:00 +0100
commit6320a8d39ef86bb956c952091baba7740ad65a9c (patch)
tree474564a708b0402fada187e57fe3b305f121441d /PKGBUILD
parenta14e77736aab5758a1e444ababbcfa2aeee99576 (diff)
downloadaur-6320a8d39ef86bb956c952091baba7740ad65a9c.tar.gz
opengothic: Add missing makedepends and follow VCS guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 29 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc41b1940ef1..c9310fdcff92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,39 @@ arch=('x86_64')
url='https://github.com/Try/OpenGothic'
license=('MIT')
depends=('alsa-lib' 'gcc-libs' 'libx11' 'vulkan-icd-loader')
-makedepends=('cmake' 'git' 'vulkan-headers')
+makedepends=('cmake' 'git' 'glslang' 'libglvnd' 'vulkan-headers')
conflicts=('bullet')
-source=("git+https://github.com/Try/OpenGothic#tag=v${pkgver}")
-sha512sums=('SKIP')
+source=("git+https://github.com/Try/OpenGothic#commit=a144bbd3917fa51d067586fcde5a27daa8fe7bad" #tag=v0.35
+ "git+https://github.com/Try/Tempest.git#commit=af9f1b4c6decdd8511d1bb302ceadc2540892580"
+ "git+https://github.com/schellingb/TinySoundFont.git#commit=d4ffcdc8a34d3f61f22e4b283b4c100f5adf4b82"
+ "git+https://github.com/Try/ZenLib.git#commit=133dab93cc8dd7c9f069fca37b2dae1409c34f30"
+ "git+https://github.com/bulletphysics/bullet3.git#commit=e7e46154bb2f4be77ad79657bcdc2675305b69a4"
+ "git+https://github.com/tito/libsquish.git#commit=f5e44a360fd8b456b1291a2eaba61871c64d6288"
+ "git+https://github.com/physfs-mirror/PhysicsFS.git#commit=a25c37f5f1552e30094234bac46a21e3e57cf9f7"
+)
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
options=('!emptydirs')
prepare() {
- cd "OpenGothic"
- git submodule update --init --recursive
+ cd "${srcdir}/OpenGothic"
+ git submodule init
+ git config submodule.lib/Tempest.url "${srcdir}/Tempest"
+ git config submodule.lib/TinySoundFont.url "${srcdir}/TinySoundFont"
+ git config submodule.lib/ZenLib.url "${srcdir}/ZenLib"
+ git config submodule.lib/bullet3.url "${srcdir}/bullet3"
+ git submodule update
+
+ cd "${srcdir}/OpenGothic/lib/ZenLib"
+ git submodule init
+ git config submodule.lib/libsquish.url "${srcdir}/libsquish"
+ git config submodule.lib/physfs.url "${srcdir}/PhysicsFS"
+ git submodule update
}
build() {