summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2021-02-13 21:03:51 +0100
committerChristopher Reimer2021-02-13 21:03:51 +0100
commita14e77736aab5758a1e444ababbcfa2aeee99576 (patch)
treed13c8816a8764d928d6fd98bfe62f02c34f8fe37 /PKGBUILD
downloadaur-a14e77736aab5758a1e444ababbcfa2aeee99576.tar.gz
Add opengothic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc41b1940ef1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Christopher Reimer <mail at c-reimer dot de>
+
+pkgname=opengothic
+pkgver=0.35
+pkgrel=1
+pkgdesc="Open source remake of Gothic 2: Night of the raven"
+arch=('x86_64')
+url='https://github.com/Try/OpenGothic'
+license=('MIT')
+depends=('alsa-lib' 'gcc-libs' 'libx11' 'vulkan-icd-loader')
+makedepends=('cmake' 'git' 'vulkan-headers')
+conflicts=('bullet')
+source=("git+https://github.com/Try/OpenGothic#tag=v${pkgver}")
+sha512sums=('SKIP')
+options=('!emptydirs')
+
+prepare() {
+ cd "OpenGothic"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "OpenGothic"
+ cmake -B build -DBUILD_SHARED_LIBS=ON -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
+}
+
+package() {
+ cd "OpenGothic"
+ DESTDIR="${pkgdir}" make -C build install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+