summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2021-08-01 14:51:11 +0200
committerChristopher Reimer2021-08-01 14:51:11 +0200
commitc85f4d77568aa2f42ef8db4e152b3b5d9ec21a65 (patch)
tree3525971a730a544852c822e06ef8d7ac62301971 /PKGBUILD
parent89216a676bc6b153ea7dad78cdd1b68ac38acddb (diff)
downloadaur-c85f4d77568aa2f42ef8db4e152b3b5d9ec21a65.tar.gz
Update opengothic 0.48
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4ac0a48d979..6a7efccfd5eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christopher Reimer <mail at c-reimer dot de>
pkgname=opengothic
-pkgver=0.37
+pkgver=0.48
pkgrel=1
pkgdesc="Open source remake of Gothic 2: Night of the raven"
arch=('x86_64')
@@ -10,13 +10,13 @@ license=('MIT')
depends=('alsa-lib' 'gcc-libs' 'libx11' 'vulkan-icd-loader')
makedepends=('cmake' 'git' 'glslang' 'libglvnd' 'vulkan-headers')
conflicts=('bullet')
-source=("git+https://github.com/Try/OpenGothic#commit=9c67441213d716416d9d8041e98d1fcf5277b40f" #tag=v0.37
- "git+https://github.com/Try/Tempest.git#commit=6507d44eebc1b2b0cdee99e155e2c447102d5eed"
+source=("git+https://github.com/Try/OpenGothic#commit=f4cf3eed8ede6a8a7a5af1cb5dab6d8c7331abf0" #tag=v0.48
+ "git+https://github.com/Try/Tempest.git#commit=48dd692e16990a812703a209c7784ea602a3fd8f"
"git+https://github.com/schellingb/TinySoundFont.git#commit=d4ffcdc8a34d3f61f22e4b283b4c100f5adf4b82"
- "git+https://github.com/Try/ZenLib.git#commit=60f536273d58412caaa393d3325945c81111724a"
+ "git+https://github.com/Try/ZenLib.git#commit=a38ad95781565607dac8ccdd06412b60c9612521"
"git+https://github.com/bulletphysics/bullet3.git#commit=e7e46154bb2f4be77ad79657bcdc2675305b69a4"
"git+https://github.com/tito/libsquish.git#commit=f5e44a360fd8b456b1291a2eaba61871c64d6288"
- "git+https://github.com/physfs-mirror/PhysicsFS.git#commit=a25c37f5f1552e30094234bac46a21e3e57cf9f7"
+ "cstddef.diff"
)
sha512sums=('SKIP'
'SKIP'
@@ -24,7 +24,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'fa0fd1a168b9368dfb5be632353f958496add647a0a62d08f593d5c0eb9df9709728aac60fa3b85dbacd54487407f51260b8fa96d984a8ff3c79c9927c486272')
options=('!emptydirs')
prepare() {
@@ -35,11 +35,12 @@ prepare() {
git config submodule.lib/ZenLib.url "${srcdir}/ZenLib"
git config submodule.lib/bullet3.url "${srcdir}/bullet3"
git submodule update
+
+ patch -p1 -i "$srcdir/cstddef.diff"
cd "${srcdir}/OpenGothic/lib/ZenLib"
git submodule init
git config submodule.lib/libsquish.url "${srcdir}/libsquish"
- git config submodule.lib/physfs.url "${srcdir}/PhysicsFS"
git submodule update
}