summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2022-11-02 00:05:08 +0100
committerChristopher Reimer2022-11-02 00:05:08 +0100
commitdee749d1932a7bd75da655740cdeafb84489034e (patch)
tree7bf2db5f255ed4ffe9d13ed582bbad56a9b447a5 /PKGBUILD
parent655cf1b352264824734b31cdbdb2e6baaa622999 (diff)
downloadaur-dee749d1932a7bd75da655740cdeafb84489034e.tar.gz
Update opengothic 0.63
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 30 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 971a7d1713f8..f60b5352e1ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,56 @@
# Maintainer: Christopher Reimer <mail at c-reimer dot de>
pkgname=opengothic
-pkgver=0.59
+pkgver=0.63
pkgrel=1
pkgdesc="Open source remake of Gothic 2: Night of the raven"
arch=('x86_64')
url='https://github.com/Try/OpenGothic'
license=('MIT')
-depends=('alsa-lib' 'gcc-libs' 'libx11' 'vulkan-icd-loader')
+depends=('alsa-lib' 'gcc-libs' 'libx11' 'vulkan-icd-loader' 'bullet' 'physfs')
makedepends=('cmake' 'git' 'glslang' 'libglvnd' 'vulkan-headers')
-conflicts=('bullet')
-source=("git+https://github.com/Try/OpenGothic#commit=2de4fd8cf49f4f4626ae715d257be7594b0b79b5" #tag=v0.59
- "git+https://github.com/Try/Tempest.git#commit=09b49484861b63f2e7676fc2eb3413b7bf12a3b8"
+source=("git+https://github.com/Try/OpenGothic#commit=15d89bca24c04bfdf287d9b5ec12a65c9cb69a49" #tag=v0.63
+ "git+https://github.com/Try/Tempest.git#commit=827449a81776ecfc8e6b34314abf5d5eb9b5134b"
"git+https://github.com/schellingb/TinySoundFont.git#commit=d4ffcdc8a34d3f61f22e4b283b4c100f5adf4b82"
- "git+https://github.com/Try/ZenLib.git#commit=0867083b2f882373f81805ba096bcf07c63e42af"
- "git+https://github.com/bulletphysics/bullet3.git#commit=ebe1916b90acae8b13cd8c6b637d8327cdc64e94"
+ "git+https://github.com/Try/ZenLib.git#commit=65b2c1f34e3d3dcd4dd6e6e1c9526996f76e0fe3"
+ "bullet_dynamic.diff"
+ "zenlib_dynamic_physfs.diff"
)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ '5aa822c283aefa0da9c75ae87e37ec66d50e71f65191187bb15e48a43fb6ea713278dd4a056e9ad04a25a622cdd85834ba5e2c4bf60bd178a46ce4eaba082981'
+ '331db32a87762503d4b6abda25369497e8e8660ea381b4363a7a6fccda65d4b1595f83fb27e05f368a943b2b00968ecb5ae8f2323a40ac85f37d68ed4bb172d0')
options=('!emptydirs')
prepare() {
+ cd "${srcdir}/ZenLib"
+ patch -p1 -i "$srcdir/zenlib_dynamic_physfs.diff"
+
cd "${srcdir}/OpenGothic"
- git submodule init
- git config submodule.lib/Tempest.url "${srcdir}/Tempest"
- git config submodule.lib/TinySoundFont.url "${srcdir}/TinySoundFont"
- git config submodule.lib/ZenLib.url "${srcdir}/ZenLib"
- git config submodule.lib/bullet3.url "${srcdir}/bullet3"
- git submodule update
+ patch -p1 -i "$srcdir/bullet_dynamic.diff"
+ rmdir lib/ZenLib
+ ln -sf "$srcdir"/ZenLib/ lib/ZenLib
+
+ rmdir lib/Tempest
+ ln -sf "$srcdir"/Tempest lib/Tempest
+
+ rmdir lib/TinySoundFont
+ ln -sf "$srcdir"/TinySoundFont lib/TinySoundFont
}
build() {
cd "OpenGothic"
- cmake -B build -DBUILD_SHARED_LIBS=ON -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -B build \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_BUILD_TYPE=None \
+ -DOpenGL_GL_PREFERENCE='GLVND' \
+ -DPHYSFS_BUILD_SHARED='OFF' \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSPIRV_CROSS_STATIC=OFF \
+ -DSPIRV_CROSS_SHARED=OFF \
+ -DSPIRV_CROSS_CLI=OFF
make -C build
}