summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2023-01-22 17:30:35 +0100
committerChristopher Reimer2023-01-22 17:30:35 +0100
commite0b4201dd8758e1888b22fce7adc077b75c445e0 (patch)
treec412e26de3e182fca575865210d33ffefe925056 /PKGBUILD
parent963a8d38e8325a970776bac2335bb7cb1508504d (diff)
downloadaur-e0b4201dd8758e1888b22fce7adc077b75c445e0.tar.gz
Update opengothic 1.0.1878
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba12daea0f96..7128676a4bd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Christopher Reimer <mail at c-reimer dot de>
pkgname=opengothic
-pkgver=0.68
+pkgver=1.0.1878
pkgrel=1
pkgdesc="Open source remake of Gothic 2: Night of the raven"
arch=('x86_64')
url='https://github.com/Try/OpenGothic'
license=('MIT')
-depends=('alsa-lib' 'gcc-libs' 'libx11' 'libxcursor' 'vulkan-icd-loader' 'spirv-cross')
+depends=('alsa-lib' 'gcc-libs' 'libx11' 'libxcursor' 'vulkan-icd-loader')
makedepends=('cmake' 'git' 'glslang' 'libglvnd' 'vulkan-headers')
-source=("git+https://github.com/Try/OpenGothic#commit=81715b1d70856a6f20d38a3e81e4ba8ba913d3e3" #tag=v0.64
+source=("git+https://github.com/Try/OpenGothic#commit=81715b1d70856a6f20d38a3e81e4ba8ba913d3e3" #tag=opengothic-v1.0.1878
"git+https://github.com/Try/Tempest.git"
"git+https://github.com/schellingb/TinySoundFont.git"
"git+https://github.com/bulletphysics/bullet3.git"
@@ -56,13 +56,9 @@ build() {
cmake -B build \
-DOpenGL_GL_PREFERENCE=GLVND \
- -DBUILD_SHARED_LIBS=OFF \
-DTEMPEST_BUILD_SHARED=OFF \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DSPIRV_CROSS_STATIC=OFF \
- -DSPIRV_CROSS_SHARED=OFF \
- -DSPIRV_CROSS_CLI=OFF
+ -DCMAKE_INSTALL_PREFIX=/usr
make -C build
}