summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcodeworkx2016-03-26 08:04:05 +0100
committercodeworkx2016-03-26 08:04:05 +0100
commit267ad00739d34b5ecbf545be6787848ff229b157 (patch)
tree1d1e4cb4ff28830f6d3732434da5f931a8d42a3a /PKGBUILD
parent2ec6ae880663604ac0777c4a546bb0d77f390bbf (diff)
downloadaur-267ad00739d34b5ecbf545be6787848ff229b157.tar.gz
skip sha1, add datestring to version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6592e2003b8b..3dab52ba9971 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Daniel Hillenbrand <codeworkx@bbqlinux.org>
pkgname=openhab-beta
-pkgver=2.0.0
+pkgver=2.0.0_20160326
pkgrel=1
pkgdesc="openHAB2 open source home automation software"
arch=('any')
@@ -19,9 +19,13 @@ source=("https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfu
noextract=("openhab-online-$pkgver-SNAPSHOT.zip")
-sha1sums=('7ecd0da3e4e15c7db37543c99d5f428427b6cd5a'
+sha1sums=('SKIP'
'3494cf262f5b87dcff75044c8c2eee670a6f715c')
+pkgver() {
+ printf "2.0.0_%s" "$(date +%Y%m%d)"
+}
+
prepare() {
mkdir -p "$srcdir/openhab"
cd "$srcdir/openhab"