summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrenton Horne2024-03-31 21:24:38 +1000
committerBrenton Horne2024-03-31 21:24:38 +1000
commit366808d3334953b7351d4687d0ad87f0a52621c5 (patch)
tree81276916126c6204662c16ae494cb0e462987430 /PKGBUILD
parentee034bc490123bd5e732f41a8e849697464069cf (diff)
downloadaur-openhv-git.tar.gz
Implementing suggested changes in comment
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bffad83c29e9..d304e46ef8a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
pkgname=openhv-git
-pkgver=2501.git.61fabc8
+pkgver=r2501.61fabc8f
pkgrel=1
pkgdesc="An open-source SciFi RTS game based on OpenRA game engine."
arch=('any')
@@ -8,17 +8,14 @@ url="https://www.openhv.net"
license=('GPL3')
depends=('mono' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme'
'gtk-update-icon-cache' 'desktop-file-utils' 'xdg-utils' 'zenity')
-makedepends=('git' 'unzip')
+makedepends=('git' 'mono-msbuild' 'unzip')
options=(!debug)
source=("git+https://github.com/OpenHV/OpenHV.git")
sha512sums=('SKIP')
pkgver() {
cd $srcdir/OpenHV
- no=$(git rev-list --count HEAD)
- hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
- version="${no}.git.${hash}"
- printf "$version"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {