summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2024-02-27 11:42:46 +0100
committerbartus2024-02-27 11:42:46 +0100
commit2c477a41ae080604febe875f186aec27e4b57089 (patch)
tree43c65fdac7ddb31fa9813efd4826ad987103d257 /PKGBUILD
parent744b38d1484da30761ebbef67abafbab50c35b2b (diff)
downloadaur-2c477a41ae080604febe875f186aec27e4b57089.tar.gz
Pop version to v2.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ceb1ff542465..38d2f1bb420e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# shellcheck disable=SC2034,SC2154 # to allow unused/uninitialized variables.
pkgname=openimagedenoise-git
-pkgver=1.4.3.r0.gd959bac
+pkgver=2.2.0.r0.gdfa3b96
#_fragment="#tag=v${pkgver}"
pkgrel=1
pkgdesc="Intel(R) Open Image Denoise library"
@@ -17,14 +17,20 @@ makedepends=(git makepkg-git-lfs-proto cmake 'ispc>=1.14' ninja)
source=("${pkgname%-git}::git+https://github.com/OpenImageDenoise/oidn.git${_fragment}"
"git+https://github.com/OpenImageDenoise/mkl-dnn.git"
"git-lfs+https://github.com/OpenImageDenoise/oidn-weights.git"
+ "git+https://github.com/NVIDIA/cutlass"
+ "git+https://github.com/ROCmSoftwarePlatform/composable_kernel"
)
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
git -C "${srcdir}"/${pkgname%-git} config submodule.mkl-dnn.url "${srcdir}"/mkl-dnn
git -C "${srcdir}"/${pkgname%-git} config submodule.weights.url "${srcdir}"/oidn-weights
+ git -C "${srcdir}"/${pkgname%-git} config submodule.cutlass.url "${srcdir}"/cutlass
+ git -C "${srcdir}"/${pkgname%-git} config submodule.external/composable_kernel.url "${srcdir}"/composable_kernel
git -C "${srcdir}"/${pkgname%-git} -c protocol.file.allow=always submodule update --init --recursive # --remote
}