summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSandy Carter2022-04-04 12:03:33 -0400
committerSandy Carter2022-04-04 12:03:33 -0400
commit1be79f91044bf6e3ed92aced52b035de41ef6025 (patch)
treed33b50d38a82379a69edb6774e5ec5f557249a74 /PKGBUILD
parent59331f9fdc8bcbdf3789422cd47b8121c5fea4d9 (diff)
downloadaur-1be79f91044bf6e3ed92aced52b035de41ef6025.tar.gz
ffmpeg: Add workaround for downstream menu bug
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b1d2171a89e..5d4d8c9b1d93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
pkgname=openmw-git
-pkgver=0.47.0.r1788.g2bd99867f
-pkgrel=2
+pkgver=0.47.0.r2137.gca77ae336
+pkgrel=1
pkgdesc="An open-source engine reimplementation for the role-playing game Morrowind."
arch=('i686' 'x86_64')
url="http://www.openmw.org"
license=('GPL3' 'MIT' 'custom')
-depends=('openal' 'openscenegraph' 'mygui' 'bullet-multithreaded' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt' 'boost-libs' 'luajit' 'recastnavigation-openmw')
+# Workaround ffmpeg4.4 https://gitlab.com/OpenMW/openmw/-/issues/6631#note_848732223
+depends=('openal' 'openscenegraph' 'mygui' 'bullet-multithreaded' 'qt5-base' 'ffmpeg4.4' 'sdl2' 'unshield' 'libxt' 'boost-libs' 'luajit' 'recastnavigation-openmw')
optdepends=('openscenegraph-openmw-git: experimental performance enhancements for OpenMW that are too controversial to be included in the general purpose OSG project')
makedepends=('git' 'cmake' 'boost')
conflicts=("${pkgname%-git}")
@@ -23,6 +24,10 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}"
+
+ # Workardoung ffmpeg4.4 https://gitlab.com/OpenMW/openmw/-/issues/6631#note_848732223
+ export PKG_CONFIG_LIBDIR='/usr/lib/ffmpeg4.4/pkgconfig/'
+
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DDESIRED_QT_VERSION=5 \