summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2022-06-17 12:01:23 +0200
committerLone_Wolf2022-06-17 12:01:23 +0200
commit74c4399a14ebaab0c744f8c0148c4da5ca78ce57 (patch)
treecd8e999151e085e38d1280d68fdbba56c1ea77d8 /PKGBUILD
parent576bff367a8d603f87398576f67e4998f1195820 (diff)
downloadaur-74c4399a14ebaab0c744f8c0148c4da5ca78ce57.tar.gz
cause of build fail without !lto found to be system-specific, removed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a28b9b8fc38..c5bb737bccce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Lone_Wolf <lone_wolf@klaas-de-kat.nl>
pkgname=openmw-git
-pkgver=0.47.0.r2799.g28c97c22b9
+pkgver=0.47.0.r2801.gcee6988093
pkgrel=1
pkgdesc="An open-source engine reimplementation for the role-playing game Morrowind."
arch=('i686' 'x86_64')
@@ -10,13 +10,11 @@ url="http://www.openmw.org"
license=('GPL3' 'MIT' 'custom')
depends=('openal' 'openscenegraph' 'mygui' 'bullet-multithreaded' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt' 'boost-libs' 'luajit' 'recastnavigation-openmw' 'yaml-cpp')
optdepends=('openscenegraph-openmw-git: experimental performance enhancements for OpenMW that are too controversial to be included in the general purpose OSG project')
-makedepends=('git' 'cmake' 'boost')
+makedepends=('git' 'cmake' 'boost' 'ninja')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=('git+https://gitlab.com/OpenMW/openmw.git')
sha1sums=('SKIP')
-# build breaks with clean chroot build using devtools without disabling lto explicitly, see https://bbs.archlinux.org/viewtopic.php?id=277304
-options=(!lto)
pkgver() {
cd "${srcdir}/${pkgname%-git}"
@@ -28,8 +26,8 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}"
-
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON
make