summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter van der Kloet2011-09-22 02:41:57 +0200
committerPieter van der Kloet2011-09-22 02:41:57 +0200
commit91049cafbeb094b80693cdddea7b3447aa16a619 (patch)
treef384d523f1eac1d819e3986a1d45845bed73aa8a /PKGBUILD
downloadaur-91049cafbeb094b80693cdddea7b3447aa16a619.tar.gz
Added PKGBUILD for openmw-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 75 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fff7509309b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+
+# Maintainer: Pieter van der Kloet <pvdkloet@gmail.com>
+pkgname=openmw-git
+pkgver=20110922
+pkgrel=1
+pkgdesc="OpenMW is a open-source engine reimplementation for the role-playing game Morrowind."
+arch=('i686' 'x86_64')
+url="http://www.openmw.org"
+license=('GPL3')
+
+depends=('openal' 'ogre' 'bullet' 'ffmpeg' 'mygui' 'mpg123' 'libsndfile' 'qt')
+
+makedepends=('git' 'cmake' 'boost')
+install=$pkgname.install
+conflicts=('openmw')
+
+_gitroot="git://github.com/zinnschlag/openmw.git"
+_gitname="openmw"
+
+build() {
+ msg "Connecting to GIT server...."
+
+ if [ -d "$_gitname" ] ; then
+ cd "$_gitname" && git pull origin
+ git submodule update
+ msg "The local files are updated."
+ else
+ cd "$srcdir"
+ git clone "$_gitroot" "$_gitname"
+ cd "$_gitname"
+ git submodule update --init
+ cd "$srcdir"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+
+ # Install
+ # There is currently no make install so we do this manually
+
+ # Binaries
+ install -d -m755 "$pkgdir"/usr/bin
+ install -m755 openmw "$pkgdir"/usr/bin/
+ install -m755 omwlauncher "$pkgdir"/usr/bin/
+ install -m755 esmtool "$pkgdir"/usr/bin/
+
+ # Config files
+ # Replace resources location
+ sed -i 's,resources=resources,resources=/usr/share/openmw/resources,' openmw.cfg.install || exit 1
+
+ install -d -m755 "$pkgdir"/etc/openmw
+ install -m644 openmw.cfg.install "$pkgdir"/etc/openmw/openmw.cfg
+ install -m644 plugins.cfg "$pkgdir"/etc/openmw/
+
+ # Stylesheet
+ install -m644 launcher.qss "$pkgdir"/etc/openmw/
+ ln -s -T /etc/openmw/launcher.qss "$pkgdir"/usr/bin/launcher.qss || exit 1
+
+ # Desktop file and icon
+ install -d -m755 "$pkgdir"/usr/share/applications
+ install -m644 files/openmw.desktop "$pkgdir"/usr/share/applications/
+
+ install -d -m755 "$pkgdir"/usr/share/pixmaps
+ install -m644 apps/launcher/resources/images/openmw.png "$pkgdir"/usr/share/pixmaps/
+
+ # Resources
+ install -d -m755 "$pkgdir"/usr/share/openmw
+ cp -r resources "$pkgdir"/usr/share/openmw/ || exit 1
+
+}
+
+