summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-02-28 21:03:12 -0300
committerDaniel Bermond2017-02-28 21:03:12 -0300
commitdfadcc3fa97664106196b7fc14164f24a4bc7576 (patch)
tree5183a4d2247768d61f1c29adf763f5b1ccca6df8 /PKGBUILD
parentbe35346318aee8b1544b83553e669760a9945ac6 (diff)
downloadaur-dfadcc3fa97664106196b7fc14164f24a4bc7576.tar.gz
Updated description, added more patches and fixed includes permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 32 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04d8bf7bb502..a788c0c1d0c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,25 +6,51 @@
pkgname=openni
pkgver=1.5.7.10
-pkgrel=3
-pkgdesc="An interface for physical devices and for middleware components"
+pkgrel=4
+pkgdesc="Framework for sensor-based 'Natural Interaction'"
arch=('i686' 'x86_64')
url="https://github.com/OpenNI/OpenNI/"
license=('APACHE')
-depends=('freeglut' 'glu' 'libusb' 'java-environment')
+depends=('freeglut' 'glu' 'libusb' 'java-environment' 'libjpeg-turbo' 'tinyxml')
makedepends=('dos2unix')
install="${pkgname}.install"
_srcprefix="OpenNI-Stable"
source=("${_srcprefix}-${pkgver}.tar.gz"::"https://github.com/OpenNI/OpenNI/archive/Stable-${pkgver}.tar.gz"
+ '0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch'
+ '0006-Use-system-wide-libjpeg.patch'
+ '0007-Use-system-wide-tinyxml.patch'
+ '0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch'
'0016-Rename-equivalent-to-fix-compilation-on-gcc6.patch'
'libopenni.pc')
sha256sums=('34b0bbf68633bb213dcb15408f979d5384bdceb04e151fa519e107a12e225852'
+ 'd967d715bc530eac42246182680d6a02e8f4c4251d38bd2aeabc38b9aabe6ebd'
+ '7690bc720b3f1a06333b6ba6ca2e44f8c1b964fa31a5c1e25c112d1a2a46ae59'
+ 'cf45346cd7c1a6d564dc4512c2b24852fc797c9ade57d7819446e214a88f3275'
+ '3f60387926942f2cad4bb775738148ac5a9fa765f8873e035d8357c8d4e34ef2'
'69cbbde667d2ad18bfb3e9933bda05d0cae36d575a4082912bbc42b7c754cd8c'
'90b67ed122eb33df96d9935421d79b620f87e791d8773e00c1406ebafd01a364')
prepare() {
cd "${srcdir}/${_srcprefix}-${pkgver}"
- dos2unix Samples/NiViewer/glh/glh_linear.h
+
+ # needed for patch 0003
+ dos2unix Samples/NiAudioSample/NiAudioSample.cpp
+ dos2unix Samples/NiCRead/NiCRead.c
+ dos2unix Samples/NiSimpleRead/NiSimpleRead.cpp
+ dos2unix Samples/NiSimpleSkeleton/NiSimpleSkeleton.cpp
+ dos2unix Samples/NiSimpleViewer/NiSimpleViewer.cpp
+ unix2dos Samples/NiSkeletonBenchmark/NiSkeletonBenchmark.cpp
+ dos2unix Samples/NiUserSelection/UserTracker.cpp
+ dos2unix Samples/NiUserTracker/main.cpp
+ dos2unix Samples/NiViewer/NiViewer.cpp
+
+ dos2unix Source/OpenNI/Linux/XnUSBLinux.cpp # needed for patch 0010
+ dos2unix Samples/NiViewer/glh/glh_linear.h # needed for patch 0016
+
+ patch -Np1 -i "${srcdir}/0003-Change-path-of-config-files-to-etc-openni-modified-for-1.5.7.10.patch"
+ patch -Np1 -i "${srcdir}/0006-Use-system-wide-libjpeg.patch"
+ patch -Np1 -i "${srcdir}/0007-Use-system-wide-tinyxml.patch"
+ patch -Np1 -i "${srcdir}/0010-Including-call-to-libusb_detach_kernel_driver-to-det.patch"
patch -Np1 -i "${srcdir}/0016-Rename-equivalent-to-fix-compilation-on-gcc6.patch"
}
@@ -56,8 +82,8 @@ package() {
# includes
cd "${srcdir}/${_srcprefix}-${pkgver}/Include"
install -D -m644 *.h "${pkgdir}/usr/include/ni"
- install -D -m755 Linux-Arm/* "${pkgdir}/usr/include/ni/Linux-Arm"
- install -D -m755 Linux-x86/* "${pkgdir}/usr/include/ni/Linux-x86"
+ install -D -m644 Linux-Arm/* "${pkgdir}/usr/include/ni/Linux-Arm"
+ install -D -m644 Linux-x86/* "${pkgdir}/usr/include/ni/Linux-x86"
# config
cd "${srcdir}/${_srcprefix}-${pkgver}/Data"