summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2021-07-27 14:43:48 +0800
committertaotieren2021-07-27 14:43:48 +0800
commitf34ecbc20f3ad321c827a44d06ea8577d274d313 (patch)
tree5bc98f68a870df649a1e225c435f9c8e1579f96b /PKGBUILD
downloadaur-f34ecbc20f3ad321c827a44d06ea8577d274d313.tar.gz
Update v20.08.00.00
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b378be555f40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=openocdcfg-generator
+pkgver=20.08.00.00
+pkgrel=1
+epoch=
+pkgdesc="This is a python tool based on pydevicetree (GitHub/PyPI) which generates OpenOCD Configuration Files for Freedom Metal applications."
+arch=('any')
+url="https://github.com/sifive/openocdcfg-generator"
+license=('Apache')
+groups=()
+depends=('python' 'openocd' 'python-jinja-time' 'python-markupsafe' 'python-pylint' 'python-pydevicetree')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=('!strip')
+install=
+changelog=
+source=("${pkgname}-${pkgver}.tar.gz::https://download.fastgit.org/sifive/openocdcfg-generator/archive/refs/tags/v${pkgver}.tar.gz")
+noextract=()
+sha256sums=('a348e9688502b88ede43c8a40b0d8a29d52620482361b2c7c0d4106b3d91a50c')
+#validpgpkeys=()
+
+package() {
+ install -Dm0755 "${srcdir}/${pkgname}-${pkgver}/generate_openocdcfg.py" "${pkgdir}/usr/bin/${pkgname}"
+
+}