summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNikolay Korotkiy2016-11-06 22:27:59 +0300
committerNikolay Korotkiy2016-11-06 22:27:59 +0300
commitb848f23185c54f313ae67b48f866f3c140249498 (patch)
treeadc044602ac974646589e2a58a05a8a88d7cb019 /PKGBUILD
parentc2104b552de4d0f9ff81b31db7a75ed51a04f9df (diff)
downloadaur-b848f23185c54f313ae67b48f866f3c140249498.tar.gz
Update translations from Weblate
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e5fe53371c7..84c52168c82e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_orgname=openorienteering
_pkgname=mapper
pkgname=${_orgname}-${_pkgname}-git
-pkgver=0.6.6.r3007.6f2fc07
-pkgrel=1
+pkgver=0.6.6.r3089.19a80d1
+pkgrel=2
pkgdesc="Orienteering mapmaking program"
arch=('i686' 'x86_64')
url="http://openorienteering.github.io/apps/mapper/"
@@ -23,6 +23,13 @@ pkgver() {
printf "%s.r%s" "${RELEASE#?}" "${REVISION}"
}
+prepare() {
+ cd ${srcdir}/${_pkgname}/translations
+ for lang in `ls OpenOrienteering_*.ts | sed 's/OpenOrienteering_\(.*\)\.ts/\1/' | grep -v template`; do
+ curl -so OpenOrienteering_$lang.ts https://hosted.weblate.org/download/${_orgname}/${_pkgname}/$lang/
+ done
+}
+
build() {
cd ${srcdir}/${_pkgname}