summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordreieck2023-05-07 17:39:22 +0200
committerdreieck2023-05-07 17:39:22 +0200
commit88da599dd4359efe73c11739b757493d37e628f6 (patch)
tree972d2642a93bb4207594479f4d2f2e999f789191 /PKGBUILD
parent9d7adc549a1fb4f0775aacb4e470d9ace6cfd997 (diff)
downloadaur-88da599dd4359efe73c11739b757493d37e628f6.tar.gz
Removing files at "site-packages/tests/" that cause conflicts with other packages.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d0a71d06fa8..8b844d446bb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
-# Maintainer: Ryan Greenblatt <ryan_greenblatt at brown dot edu>
-#
+# Contributor: Ryan Greenblatt <ryan_greenblatt at brown dot edu>
# Contributor: Paul Nicholson <brenix@gmail.com>
pkgname=openpyn-nordvpn
pkgver=3.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Easily connect to and switch between OpenVPN servers hosted by NordVPN"
provides=('python-openpyn' 'openpyn-nordvpn')
arch=('any')
url="https://github.com/jotyGill/openpyn-nordvpn"
license=('GPLv3')
depends=('openvpn' 'systemd' 'python-humanfriendly' 'python-requests' 'python-colorama' 'python-coloredlogs' 'python-verboselogs' 'python-tqdm' 'python-jsonschema' 'wget' 'unzip')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
install="${pkgname}.install"
source=("https://github.com/jotyGill/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
sha512sums=('78cd9984f82bcd1cde4d0a798c79599629fe9fd0d9ac72fb1a464dd415019379e530cc3ac360637b65e67b3bebd54289654555e7ce0786c1e525434e23713356')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --skip-build -O1 --root="${pkgdir}"
+ python -m installer --destdir="$pkgdir" --compile-bytecode=2 dist/*.whl
+
+ rm -f "${pkgdir}/usr/lib"/python*/site-packages/tests/{__init__.py,__pycache__/__init__.cpython-*.opt-2.pyc}
}
+