summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEden Rose2017-10-13 12:54:32 -0400
committerEden Rose2017-10-13 12:54:32 -0400
commitfbcbd005cb36f22b4f9215f75931e173e039aaa1 (patch)
tree61dec0f933e2baa36c3c7fc5d699af59737569de /PKGBUILD
parent34b9c3f3484143a268dcf4f62deabc526853237c (diff)
downloadaur-fbcbd005cb36f22b4f9215f75931e173e039aaa1.tar.gz
Fixed, sorry for the delay
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb47d89f9548..617b8017f2f4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Matthew Bowra-Dean <matthew@ijw.co.nz>
#
pkgname=openra-git
-pkgver=BLEED.20171009.249e81344
+pkgver=BLEED.20171013.249e81344
pkgrel=1
pkgdesc="An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL. DuneII and Red Alert 2, mods Included. -GIT VERSION"
arch=('any')
@@ -57,7 +57,8 @@ build() {
fi
ln -s ../OpenRA engine
#patch -p1 mod.config < $srcdir/RA2-mod.config.patch
- cat mod.config | sed -e s/$SPEC_VER/'"{DEV_VERSION}"'/g > mod.config.1
+ SPEC_VER="$(cat mod.config | grep ENGINE_VERSION | sed -e 's/=/\n/g' | head -2 | tail -1)"
+ cat mod.config | sed -e s/"$SPEC_VER"/'"{DEV_VERSION}"'/g > mod.config.1
mv mod.config.1 mod.config
make