summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuca Weiss2023-05-23 23:12:09 +0200
committerLuca Weiss2023-05-23 23:12:09 +0200
commit2e14f5e57804c3bef8a2934816e0b2a9f8c76bf4 (patch)
tree616d5698f0266fce5467c724d407c553304d58f5 /PKGBUILD
parentc45bb9c5f03f1786c5caec9f2ccbb359cc52d417 (diff)
downloadaur-openrazer.tar.gz
openrazer: remove python sanity check
Seems people are annoyed at this, so let's see how many people have messed up Python setups that will complain about the build not working without this extra check telling them.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 0 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b389069fa79..6f8d0889b4e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,16 +13,6 @@ makedepends=('python-setuptools')
source=("https://github.com/openrazer/openrazer/releases/download/v$pkgver/openrazer-$pkgver.tar.xz")
sha256sums=('bbb33fc3fbe329d178793fe3e24e60cbe5369c5996b8e1546de2950669ef675b')
-prepare() {
- # Do a sanity check in the environment of the builder so the build process doesn't place files into a wrong directory.
- # If you think this is incorrect you can always remove this from the PKGBUILD, but then please don't complain if it doesn't work.
- if [ "$(which python3)" != "/usr/bin/python3" ]; then
- echo "ERROR: Your 'python3' does not point to /usr/bin/python3 but to $(which python3), likely a custom environment like anaconda."
- echo "Please build this package in a clean chroot (e.g. with https://wiki.archlinux.org/title/DeveloperWiki:Building_in_a_clean_chroot) or point your PATH variable to prefer /usr/bin/ temporarily."
- return 1
- fi
-}
-
package_python-openrazer() {
pkgdesc="Python library for accessing the Razer daemon from Python."
depends=('openrazer-daemon' 'python-numpy')