summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed John2017-07-14 00:22:50 +0100
committerTed John2017-07-14 00:22:50 +0100
commitaa2365499a55a29e624cba2dc89b1de64582ed56 (patch)
treefae236abccc5223be908f094008fccbe03a41875 /PKGBUILD
downloadaur-openrct2-cli.tar.gz
Add first pkgbuild for openrct2-cli
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..832359873ce5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Ted John <intelorca@gmail.com>
+pkgname=openrct2-cli
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='OpenRCT2, command line interface (headless).'
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url='https://openrct2.website'
+license=('GPL3')
+depends=('libopenrct2')
+makedepends=('cmake')
+source=("https://github.com/OpenRCT2/OpenRCT2/archive/v$pkgver.tar.gz")
+sha256sums=('0347a47d380fc18ea543928c92a13d1bdb4431573154afeb80fa33f1149e6992')
+
+build() {
+ cd "$srcdir/OpenRCT2-$pkgver"
+
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr ..
+ make openrct2-cli
+}
+
+package() {
+ cd "$srcdir/OpenRCT2-$pkgver/build"
+
+ make DESTDIR="$pkgdir" install
+ cp openrct2-cli "$pkgdir/usr/bin"
+ cd "$pkgdir/usr"
+
+ # Currently the install target builds openrct2 which we don't want
+ # we also need to remove the stuff that is installed with libopenrct2
+ rm -rf bin/openrct2 lib share/applications share/icons share/doc/openrct2 share/openrct2
+
+ # Symlink openrct2 to openrct2-cli
+ cd bin
+ ln -s openrct2-cli openrct2
+}