summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBo Davidson2021-01-16 09:47:08 -0600
committerBo Davidson2021-01-16 09:47:08 -0600
commit7b73024ef8330d731a1b9186e7e0999d7f87b958 (patch)
treedf5c3e4600099810a4433d14d42bf58100ff5b97 /PKGBUILD
parent6bd8d4e3678798aa0441f08605d77ead0a288594 (diff)
downloadaur-7b73024ef8330d731a1b9186e7e0999d7f87b958.tar.gz
re-implementing loading of i2c module by default
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6523ca11c986..854466a77e8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Paul Davis <paul@dangersalad.com>
pkgname=openrgb
pkgver=0.5
-pkgrel=5
+pkgrel=6
pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
@@ -10,14 +10,15 @@ license=('GPL2')
depends=('qt5-base' 'libusb' 'hidapi')
makedepends=('pkgconf')
optdepends=('i2c-tools: Motherboard & RAM access')
-conflicts=('openrgb-git')
source=(
"https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
hidapifix.patch # https://gitlab.com/CalcProgrammer1/OpenRGB/-/issues/924
+ openrgb.conf
)
sha256sums=(
'e227dedfe0c3aa8f3bcb0c4149aa5feb1db4b0429a151423d74c0103c55d7d26'
'eeaed61a7bdbfa98cd9aaa6ea8a55df3eb092bc1f02ba047dd73cf75d1578b88'
+ 'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2'
)
prepare() {
@@ -43,4 +44,5 @@ build() {
package() {
cd "$srcdir/OpenRGB-release_$pkgver"
make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 -t "$pkgdir"/usr/lib/modules-load.d ../openrgb.conf
}