summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBo Davidson2023-05-21 07:59:12 -0500
committerBo Davidson2023-05-21 07:59:12 -0500
commit9a0fed4dcafcd333e600ec7ee13883fcec151fa5 (patch)
tree44da60bedc018af402016104c1a0a5dcf8b32aea /PKGBUILD
parentc80c9416f701c7e4264277a878f68cfb491698df (diff)
downloadaur-9a0fed4dcafcd333e600ec7ee13883fcec151fa5.tar.gz
Build fix /w patch, linking mbedtls2, removes -pipe msgs
Thanks to AndyRTR for fix. https://aur.archlinux.org/packages/openrgb#comment-915525 Tested in clean chroot.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b73fc82730ee..e17b8a1680ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Paul Davis <paul@dangersalad.com>
pkgname=openrgb
pkgver=0.8
-pkgrel=1
+pkgrel=2
pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
@@ -21,12 +21,15 @@ source=(
"https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
openrgb.conf
openrgb.service
+ 1743.patch # https://gitlab.com/CalcProgrammer1/OpenRGB/-/merge_requests/1743.patch
)
sha256sums=('0d803753873ca1ec2bd78632b4ac605669394e7eeba2d2efe305c7f9c9d7df0c'
'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2'
- '272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938')
+ '272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938'
+ '2f7fe2fa62731884f16ebf5d4bb22bb2366e300d292bc3a113a8689d1cc14109')
prepare() {
+ # Searches and applies any .patch file included this git repo
cd "$srcdir/OpenRGB-release_$pkgver"
local src
for src in "${source[@]}"; do
@@ -40,9 +43,12 @@ prepare() {
build() {
+ export CXXFLAGS=${CXXFLAGS/-pipe}
+ export LDFLAGS="$LDFLAGS -L/usr/lib/mbedtls2" # props to AndyRTR for linking to mbedtls2 fix
+
cd "$srcdir/OpenRGB-release_$pkgver"
sed -i 's|rules.path=/lib|rules.path=/usr/lib|g' OpenRGB.pro
- qmake OpenRGB.pro
+ qmake INCLUDEPATH+="/usr/include/mbedtls2" OpenRGB.pro
make
}