summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordangersalad2020-05-15 10:26:03 -0600
committerdangersalad2020-05-19 09:35:21 -0600
commitc2de57e91c9bf8d54d5d2d018cf1542b50a02afb (patch)
tree641f1658c1caae3a486a56430699ead3786c460e /PKGBUILD
downloadaur-c2de57e91c9bf8d54d5d2d018cf1542b50a02afb.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e2ef8b14467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Paul Davis <paul@dangersalad.com>
+pkgname=openrgb
+pkgver=0.2
+pkgrel=1
+pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software"
+arch=("x86_64")
+url="https://gitlab.com/CalcProgrammer1/OpenRGB"
+license=('GPL2')
+depends=('qt5-base' 'libusb')
+optdepends=('linux-openrgb: ASUS and ASRock motherboard support')
+provides=("openrgb")
+source=("https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz")
+md5sums=('aba82b83744b04d5fe1728aea85b5a62')
+
+build() {
+ cd "OpenRGB-release_$pkgver"
+ qmake OpenRGB.pro
+ make
+}
+
+package() {
+ install -Dm755 "$srcdir/OpenRGB-release_$pkgver/OpenRGB" "$pkgdir"/usr/bin/OpenRGB
+}