summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLaura Demkowicz-Duffy2022-02-14 15:55:49 +0000
committerLaura Demkowicz-Duffy2022-02-14 15:55:49 +0000
commit186a3857ed1ac6a6eb7c5fc23248fa4add23f54f (patch)
tree556f616a76c2a0d12f11cca3e9579fdbaf01e547 /PKGBUILD
parent545904bcb4a739e6d0b42d2a332b1da2f2d38092 (diff)
downloadaur-186a3857ed1ac6a6eb7c5fc23248fa4add23f54f.tar.gz
fix: new motor database packaging method
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 101be26f6d2c..332b5e737055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Laura Demkowicz-Duffy <laura@demkowiczduffy.co.uk>
pkgname=openrocket-git
-pkgver=r2980.52314dbc
+pkgver=r3149.c40acb7c
pkgrel=1
pkgdesc="A free and fully featured rocket flight simulator - 6 degrees of freedom"
arch=('any')
@@ -11,9 +11,11 @@ makedepends=('git' 'ant')
provides=('openrocket')
conflicts=('openrocket')
source=("git+https://github.com/openrocket/openrocket.git#branch=unstable"
+ "git+https://github.com/dbcook/openrocket-database.git"
"openrocket.sh")
noextract=("openrocket.sh")
sha256sums=('SKIP'
+ 'SKIP'
'74ab605cb11161784d4af96d018eb88adf7a2e4a8b1088a64b94b1e8ec5e18d1')
pkgver() {
@@ -21,6 +23,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd openrocket
+ git submodule init
+ git config submodule.swing/resources-src/datafiles/components.url "$srcdir/openrocket-database"
+ git submodule update
+}
+
build() {
cd openrocket
ant -noinput -buildfile ./build.xml jar