summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLaura Demkowicz-Duffy2021-12-26 18:50:42 +0000
committerLaura Demkowicz-Duffy2021-12-26 18:50:42 +0000
commit545904bcb4a739e6d0b42d2a332b1da2f2d38092 (patch)
tree10348754ae1f4db8c3b0b10b51f032cf30691274 /PKGBUILD
parent4cc684c0c7029d7c20ae4ef9091c9b12c3830b19 (diff)
downloadaur-545904bcb4a739e6d0b42d2a332b1da2f2d38092.tar.gz
Bump version, add check step, bump to JDK 11, use more verbose ant flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3430f2b35182..101be26f6d2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Laura Demkowicz-Duffy <laura@demkowiczduffy.co.uk>
pkgname=openrocket-git
-pkgver=r2977.459d4ab4
-pkgrel=2
+pkgver=r2980.52314dbc
+pkgrel=1
pkgdesc="A free and fully featured rocket flight simulator - 6 degrees of freedom"
arch=('any')
url=https://github.com/openrocket/openrocket
license=('GPL3')
-depends=('java-environment=8' 'desktop-file-utils')
+depends=('java-environment=11' 'desktop-file-utils')
makedepends=('git' 'ant')
provides=('openrocket')
conflicts=('openrocket')
@@ -23,7 +23,12 @@ pkgver() {
build() {
cd openrocket
- ant -f ./build.xml
+ ant -noinput -buildfile ./build.xml jar
+}
+
+check() {
+ cd openrocket
+ ant -noinput -buildfile ./build.xml check unittest
}
package() {