summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLaura Demkowicz-Duffy2021-10-29 02:48:07 +0100
committerLaura Demkowicz-Duffy2021-10-29 02:48:07 +0100
commit6f5c6fb4594d1e6b1d915cfa4287d33d47c8b198 (patch)
treef25f8df991abceb537fdc1967f13d7c39b32d141 /PKGBUILD
downloadaur-6f5c6fb4594d1e6b1d915cfa4287d33d47c8b198.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34feb696aba0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Laura Demkowicz-Duffy <laura@demkowiczduffy.co.uk>
+pkgname=openrocket-git
+pkgver=r2955.f67ea41c
+pkgrel=1
+pkgdesc="A free and fully featured rocket flight simulator - 6 degrees of freedom"
+arch=('any')
+url=https://github.com/openrocket/openrocket
+license=('GPL')
+depends=('java-environment=8' 'desktop-file-utils')
+makedepends=('git' 'ant')
+provides=('openrocket')
+conflicts=('openrocket')
+source=("git+https://github.com/openrocket/openrocket.git#branch=unstable"
+ "openrocket.sh")
+noextract=("openrocket.sh")
+sha256sums=('SKIP'
+ '74ab605cb11161784d4af96d018eb88adf7a2e4a8b1088a64b94b1e8ec5e18d1')
+
+pkgver() {
+ cd openrocket
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd openrocket
+ ant -f ./build.xml
+}
+
+package() {
+ cd openrocket
+ install -Dm644 swing/build/jar/OpenRocket.jar $pkgdir/usr/share/java/openrocket/openrocket.jar
+}