summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSameer Puri2023-05-23 13:25:05 -0700
committerSameer Puri2023-05-23 13:25:21 -0700
commit5cc25357dbb9d3608123cd455bcd4db305558023 (patch)
treee7d6c7e48bed3b3b2e732ecce6f3db426eca5478 /PKGBUILD
parent5d98a18bb156ad433b57b445f2286c169dbb8cda (diff)
downloadaur-5cc25357dbb9d3608123cd455bcd4db305558023.tar.gz
update build, remove deprecated aurinfo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae3ea55cade0..5d9617066433 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=openscad-git
_pkg="${pkgname%-git}"
-pkgver=2019.05.r2561.gbc21c1263
-pkgrel=1
+pkgver=2019.05.r2660.gab30ab63b
+pkgrel=2
pkgdesc="The programmers solid 3D CAD modeller"
arch=('x86_64')
license=('GPL2')
@@ -21,7 +21,8 @@ depends=(
'qt5-base'
'qt5-gamepad'
'qt5-multimedia'
- 'qt5-svg')
+ 'qt5-svg'
+ 'tbb')
makedepends=('git' 'boost' 'cmake' 'eigen' 'imagemagick' 'python')
source=("$_pkg::git+$url"
'MCAD::git+https://github.com/openscad/MCAD'
@@ -41,6 +42,7 @@ prepare() {
git config submodule.libraries/MCAD.url "$srcdir/MCAD"
git -c protocol.file.allow=always submodule update
sed -i 's/ping files.openscad.org/ping archlinux.org/' resources/CMakeLists.txt
+ git submodule update --init --recursive
}
build() {