summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArsen Musayelyan2020-04-19 15:02:47 -0700
committerArsen Musayelyan2020-04-19 15:02:47 -0700
commit281c2f2c7ccfdc854b2b1d403357856e38ee56ba (patch)
treea86525318a2e4cc6407b4d13d587ba4c5f13fa07 /PKGBUILD
downloadaur-281c2f2c7ccfdc854b2b1d403357856e38ee56ba.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2d05533eca0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Arsen Musayelyan <moussaelianarsen@gmail.com>
+pkgname=opensend-git
+pkgver=r38.003c27d
+pkgrel=1
+pkgdesc="Send files and URLs securely across systems"
+arch=('any')
+license=('GPLv2')
+depends=('python' 'python-pip' 'python-pynacl' 'python-zeroconf' 'python-pyftpdlib' 'python-pyqt5')
+source=('git+https://gitlab.com/moussaelianarsen/opensend.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/opensend"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$srcdir/opensend"
+ DESTDIR="$pkgdir/" SUPRESSPIP=true python3 install.py
+ # Install PyAESCrypt using pip as it is not available in repos or AUR
+ python3 -m pip install pyAesCrypt
+}