summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAriel Lieberman2018-06-22 02:10:13 +0300
committerAriel Lieberman2018-06-22 02:10:13 +0300
commitc0cf24355ae392168ac23ac7ba79a286d9681d1a (patch)
treeb1eb88711f2823db2eb63d47199738d763907560 /PKGBUILD
downloadaur-c0cf24355ae392168ac23ac7ba79a286d9681d1a.tar.gz
On branch master
Initial commit Changes to be committed: new file: .SRCINFO new file: PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a71771ce8dbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Ariel Lieberman <rellieberman at gmail dot com>
+
+#This package conflicts with culmus because it contains all culmus fonts as well.
+
+#If you find other conflicts you can remove those fonts from this PKGBUILD,
+#see the last line and an example were I removed Liberation fonts since they are contained in other packages.
+
+pkgname=open-siddur-hebrew-fonts
+pkgver=1.18.2
+pkgrel=1
+pkgdesc="The Open Siddur Project's open-source Unicode Hebrew font pack.
+open-source licensed Unicode fonts in Hebrew, Latin, Greek, Cyrillic, Arabic, and Amharic scripts"
+
+url="https://github.com/aharonium/fonts"
+arch=(any)
+license=('GPL 3.0'
+ 'GPL-FE'
+ 'OFL'
+ 'APACHE'
+ 'UBL'
+ 'LPPL'
+ 'GPL 2.0')
+depends=('fontconfig' 'xorg-fonts-alias' 'xorg-font-utils' 'xorg-fonts-encodings')
+conflicts=('culmus')
+_zipname=master
+source=("$_zipname.zip::https://github.com/aharonium/fonts/archive/$_zipname.zip")
+sha256sums=('SKIP')
+
+prepare() {
+ find "${srcdir}" -type f ! -perm 644 -exec chmod 644 {} +
+}
+
+
+package() {
+ cd $srcdir
+
+ mkdir $pkgdir/usr/
+ mkdir $pkgdir/usr/share/
+ mkdir $pkgdir/usr/share/fonts/
+ mkdir $pkgdir/usr/share/fonts/TTF/
+ mkdir $pkgdir/usr/share/fonts/OTF/
+
+ find "${srcdir}" -type f -name "*.ttf" -exec cp "{}" $pkgdir/usr/share/fonts/TTF/ ";"
+ find "${srcdir}" -type f -name "*.otf" -exec cp "{}" $pkgdir/usr/share/fonts/OTF/ ";"
+
+ #remove Liberation to prevent conflict
+ find "${pkgdir}" -type f -name "Liberation*" -exec rm "{}" ";"
+
+ #remove other font families but running:
+ # find "${pkgdir}" -type f -name "<font-family>*" -exec rm "{}" ";"
+}
+