summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2016-02-19 23:04:21 -0300
committerHugo Osvaldo Barrera2016-02-19 23:10:49 -0300
commitcb392994e8896d30164b8d3e2f95aa144a362cfb (patch)
tree2649f2fe888f2150b2dc34f8356640fa2546932e /PKGBUILD
parent1a05fe3249e381a98ee6ce0937c589dfd756edd7 (diff)
downloadaur-cb392994e8896d30164b8d3e2f95aa144a362cfb.tar.gz
Update flags and create missing symlinks
Flags were renamed and cleaned up upstream. Update existing ones, and delete for which we use the default value. Upstream also axed several links (since they interfere with other distributions). Explicitly create these.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e4c6236421d..d5f70c0dc286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=opensmtpd-snapshot
_pkgname=opensmtpd
pkgver=201602131907p1
-pkgrel=1
+pkgrel=2
pkgdesc='A FREE implementation of the server-side SMTP protocol. Latest snapshot.'
arch=('i686' 'x86_64')
url="http://www.opensmtpd.org/portable.html"
@@ -36,13 +36,8 @@ build() {
--sysconfdir=/etc/mail \
--sbindir=/usr/bin \
--libexecdir=/usr/lib/smtpd \
- --with-sock-dir=/run \
- --with-privsep-path=/var/empty \
- --with-privsep-user=_smtpd \
- --with-queue-user=_smtpq \
- --with-filter-user=_smtpf \
- --with-pam \
- --with-ca-file=/etc/ssl/certs/ca-certificates.crt
+ --with-path-CAfile=/etc/ssl/certs/ca-certificates.crt \
+ --with-table-db
make
}
@@ -50,6 +45,9 @@ package() {
cd "$srcdir/${_pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install
+ ln -s /usr/bin/smtpctl "$pkgdir/usr/bin/makemap"
+ ln -s /usr/bin/smtpctl "$pkgdir/usr/bin/newaliases"
+ ln -s /usr/bin/smtpctl "$pkgdir/usr/bin/sendmail"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"