summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlsf2021-09-14 15:10:49 +0200
committerlsf2021-09-14 15:10:49 +0200
commit6f004a3e89ea11e7e19115489e7ef976da0e4c52 (patch)
tree115fd6991f7c0526a22d6d34944d96db92e1b060 /PKGBUILD
parentf9af2fde676b97788e6f36ea3b2ba8963ffc3a11 (diff)
downloadaur-6f004a3e89ea11e7e19115489e7ef976da0e4c52.tar.gz
update kver; fix pkgver so rc does not produce odd versions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21504945a710..86df35a039e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=opensnitch-ebpf-module-git
_pkgname=opensnitch
-pkgver=1.4.0.rc.2.r27.8580281
+pkgver=1.4.0.r3.c66d5d6
pkgrel=1
-_kver=5.12
+_kver=5.13
pkgdesc="eBPF process monitor module for opensnitch"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/evilsocket/opensnitch"
@@ -17,11 +17,11 @@ conflicts=("${pkgname%-git}")
source=('git+https://github.com/evilsocket/opensnitch.git'
"https://github.com/torvalds/linux/archive/v${_kver}.tar.gz")
sha256sums=('SKIP'
- '1c9334afe7a3b805d8d5127ee31441418c795242a3ac30789fa391a0bdeb125b')
+ '9ce4c15b10d4dc9e353f3105dd11b9d2d2ef83e24772d68d3cf0830fe5f527a1')
pkgver() {
cd "$srcdir/${_pkgname}"
- git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+ git describe --long | sed 's/^v//;s/rc\.[0-9]*-//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {