summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorevs-ch2018-09-18 12:13:45 +0200
committerevs-ch2018-09-18 12:14:05 +0200
commit14027ef83eb9aa32cb0726bf17761491fefcde95 (patch)
treeddf2af11f5ea04351c6f7050f6e8ce0b7519ef08 /PKGBUILD
parent7a3f8a681607a83a7904a1cd75f9607ae84f9f15 (diff)
downloadaur-14027ef83eb9aa32cb0726bf17761491fefcde95.tar.gz
explicit -git dependencies, until I find out what causes this
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index faecbdc46bbd..e45d7959114a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: lsf
# Maintainer: Adam Hose <adis@blad.is>
pkgver=20180913.350_e9c10b9
-pkgrel=1
+pkgrel=2
pkgbase=opensnitch-git
_pkgbase=opensnitch
pkgname=("${_pkgbase}-git" "${_pkgbase}-ui-git")
@@ -12,7 +12,7 @@ makedepends=('git' 'go-pie' 'dep' 'libpcap' 'protobuf'
'python-setuptools' 'python-pip'
'python-grpcio' 'python-grpcio-tools'
'python-pyinotify' 'python-pyqt5'
- 'python-unicode-slugify')
+ 'python-unicode-slugify-git')
source=("git://github.com/evilsocket/opensnitch.git"
'nosudo.patch'
@@ -61,7 +61,7 @@ build() {
package_opensnitch-git() {
pkgdesc="A GNU/Linux port of the Little Snitch application firewall."
- optdepends=('opensnitch-ui')
+ optdepends=('opensnitch-ui-git')
depends=('libnetfilter_queue')
export GOPATH="$srcdir/.go"
@@ -74,7 +74,7 @@ package_opensnitch-git() {
package_opensnitch-ui-git() {
pkgdesc="UI for opensnitch."
depends=('python-grpcio' 'python-grpcio-tools' 'python-pyinotify'
- 'python-pyqt5' 'python-unicode-slugify' 'opensnitch'
+ 'python-pyqt5' 'python-unicode-slugify-git' 'opensnitch-git'
'desktop-file-utils')
export GOPATH="$srcdir/.go"