summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpobrn2022-11-15 22:35:55 +0100
committerBarnabás Pőcze2022-11-15 22:35:55 +0100
commite25566daead1c30e0d9bf929584c81ee9219c140 (patch)
treebd5e23c755122c94acee0b895510e38487310d89 /PKGBUILD
parent06448d39a58d3ee14f976c1141a9d24f782c4404 (diff)
downloadaur-openspades-git.tar.gz
use cmake for building and installing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f27d8a27df73..0c82b6793bb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,16 +24,16 @@ pkgver() {
}
build() {
- cd "$pkgname"
- cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=RelWithDebInfo \
+ cmake -B build -S "${pkgname}" \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_BUILD_TYPE=RelWithDebInfo \
-D OPENSPADES_RESDIR=/usr/share/$_pkgname/Resources \
-D OPENSPADES_INSTALL_RESOURCES=share/$_pkgname/Resources \
- -D OPENSPADES_INSTALL_BINARY=bin .
- make
+ -D OPENSPADES_INSTALL_BINARY=bin
+ cmake --build build
}
package() {
- cd "$pkgname"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
rm -rf "${pkgdir}/usr/share/menu"
}