summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamuel Walladge2016-03-07 11:02:30 +1030
committerSamuel Walladge2016-03-07 11:02:30 +1030
commit64d764bbc63bb7293443e7dc36e59eaf54d8c490 (patch)
tree4c57d9f804fd3b7295485f1aa73d1aa8fc240084 /PKGBUILD
parent5b3fd7c898da028bfc614d68fd49405508e88fe5 (diff)
downloadaur-64d764bbc63bb7293443e7dc36e59eaf54d8c490.tar.gz
patched to fix build errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfe79a51c5d4..d97278d46c89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: kusakata <shohei atmark kusakata period com>
pkgname=openspades-git
-pkgver=0.0.12.59.g50abf95
-pkgrel=1
+pkgver=0.0.12.84.g355d1f2
+pkgrel=2
pkgdesc="A clone of Voxlap Ace of Spades 0.75 (git version)"
arch=('i686' 'x86_64')
url="https://github.com/yvt/openspades"
@@ -14,22 +14,31 @@ makedepends=('cmake' 'git' 'unzip' 'wget')
provides=('openspades')
conflicts=('openspades')
install=openspades.install
-source=("$pkgname"::'git://github.com/yvt/openspades.git')
-md5sums=('SKIP')
+source=("$pkgname"::'git+https://github.com/yvt/openspades.git'
+ 'openspades.patch')
+md5sums=('SKIP'
+ 'f8b429ee14d92598fd684fcf4ce3097e')
+
+prepare() {
+ # Note: this being the git version, possibly soon be fixed/modified upstream and patch becomes obsolete/invalid
+ # if patching or building with this patch fails, please notify the package maintainer
+ cd "${srcdir}/${pkgname}"
+ patch -p1 -i ${srcdir}/openspades.patch
+}
pkgver() {
- cd "$pkgname"
- git describe --tags | sed 's/^v//' | sed 's/-/./g'
+ cd "$pkgname"
+ git describe --tags | sed 's/^v//' | sed 's/-/./g'
}
build() {
- cd "$pkgname"
- cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release -D OPENSPADES_RESDIR=/usr/share/openspades-git/Resources -D OPENSPADES_INSTALL_RESOURCES=share/openspades-git/Resources -D OPENSPADES_INSTALL_BINARY=bin .
- make
+ cd "$pkgname"
+ cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release -D OPENSPADES_RESDIR=/usr/share/openspades-git/Resources -D OPENSPADES_INSTALL_RESOURCES=share/openspades-git/Resources -D OPENSPADES_INSTALL_BINARY=bin .
+ make
}
package() {
- cd "$pkgname"
- make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}/usr/share/menu"
+ cd "$pkgname"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr/share/menu"
}