summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNoah Vogt2022-11-29 14:27:01 +0100
committerNoah Vogt2022-11-29 14:27:01 +0100
commitd76ad79c3be235e163fb79a1e1ae427eb3254cea (patch)
treeaac6694a1cf15879d93a85b1df76ef0e700626ba /PKGBUILD
downloadaur-d76ad79c3be235e163fb79a1e1ae427eb3254cea.tar.gz
uppkg -> 9.1p1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d905bce162c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Noah Vogt (noahvogt) <noah@noahvogt.com>
+pkgname=openssh-dotconfig-bin
+pkgver=9.1p1
+pkgrel=2
+pkgdesc="NetworkManager VPN plugin for OpenVPN - with Support for the XDG Base Directory Specification (binary version)"
+pkgdesc='Premier connectivity tool for remote login with the SSH protocol - but moved $HOME/.ssh to $HOME/.config/ssh (binary version)'
+url='https://www.openssh.com/portable.html'
+license=('custom:BSD')
+arch=(x86_64)
+depends=(libnm libsecret openvpn)
+depends=('glibc' 'krb5' 'openssl' 'libedit' 'ldns' 'libxcrypt' 'libcrypt.so' 'zlib' 'pam')
+optdepends=('xorg-xauth: X11 forwarding'
+ 'x11-ssh-askpass: input passphrase in X'
+ 'libfido2: FIDO/U2F support')
+source=("https://github.com/noahvogt/${pkgname%-*}-aur/releases/download/$pkgver-$pkgrel/${pkgname%-*}-$pkgver-$pkgrel-$arch.pkg.tar.zst")
+sha256sums=('992fa4b4f285024a07a671b49b0f63c90070a033ffc48f96f088c4cef217360d')
+provides=('openssh')
+conflicts=('openssh')
+
+package() {
+ cp -R "${srcdir}/usr/" "${pkgdir}/usr"
+ cp -R "${srcdir}/var/" "${pkgdir}/var"
+ cp -R "${srcdir}/etc/" "${pkgdir}/etc"
+}