summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2017-09-24 09:49:23 +0300
committerChristoph Gysin2017-09-26 21:18:22 +0300
commitf4e5e06c0dea73779c1bd5ab0a6b5a4547804dcd (patch)
treeefe0e6388fb0927b17042547b6e67127d9fc323d /PKGBUILD
parent3dc6a26eca1561aa67cba91746dabfe3c3090ec0 (diff)
downloadaur-f4e5e06c0dea73779c1bd5ab0a6b5a4547804dcd.tar.gz
build against openssl-1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1191e4ec13f..8c1b891fba78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ arch=('i686' 'x86_64')
makedepends=('linux-headers')
conflicts=(${_pkgname})
provides=(${_pkgname})
-depends=('krb5' 'openssl' 'libedit' 'ldns')
+depends=('krb5' 'openssl-1.0' 'libedit' 'ldns')
optdepends=('xorg-xauth: X11 forwarding'
'x11-ssh-askpass: input passphrase in X')
validpgpkeys=('59C2118ED206D927E667EBE3D3E5F56B6D920D30')
@@ -48,6 +48,13 @@ build() {
patch -p1 -i ../gssapi-p0.patch
patch -p1 -i ../gssapi-p1.patch
patch -p1 -i ../gssapi-p2.patch
+
+ # compile against openssl-1.0
+ ssldir="$srcdir"/openssl-1.0
+ mkdir "$ssldir"
+ ln -s /usr/include/openssl-1.0 "$ssldir"/include
+ ln -s /usr/lib/openssl-1.0 "$ssldir"/lib
+
./configure \
--prefix=/usr \
--sbindir=/usr/bin \
@@ -64,6 +71,7 @@ build() {
--with-md5-passwords \
--with-pid-dir=/run \
--with-gssapi \
+ --with-ssl-dir="$ssldir"
make
}