summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBjörn Wiedenmann2015-12-06 22:03:18 +0100
committerBjörn Wiedenmann2015-12-06 22:58:30 +0100
commit5e372b0bdd5907d41011419ecbea38fc6ecc881f (patch)
tree1bd16e8623c6e20b4a927df384440074f556156e /PKGBUILD
parent9ca4547b23591d82e84ed84f33c8153878d3aac6 (diff)
downloadaur-5e372b0bdd5907d41011419ecbea38fc6ecc881f.tar.gz
Updated package to latest upstream version
The function pkgver() depends on the upstream tags. The way this function was originally implemented seems unable to create strictly monotonous version numbers because the revision is not properly increased. Whether a version is higher or lower depends solely on the commit hash which is somewhat random. I suspect part of the problem might also be the way the project is tagged upstream, possibly overwriting tags. Making the function use only annotated tags seems to fix the issue for now, but I will re-visit this later, especially since openssh-git is using the same method for deriving a version number.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6f1d8b4482f..99ce1bd81a2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,8 +37,8 @@
# please use the official OpenSSH distribution instead.
pkgname=openssh-hpn-git
-pkgver=7.1.P1.r0.g3d385de
-pkgrel=1
+pkgver=7.1.P1.r27.g764931d
+pkgrel=2
pkgdesc='A Secure SHell server/client fork with High Performance patches included'
url='http://www.psc.edu/networking/projects/hpn-ssh/'
license=('custom:BSD')
@@ -76,7 +76,7 @@ install=$pkgname.install
pkgver() {
cd openssh-portable/
- if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ if GITTAG="$(git describe --abbrev=0 2>/dev/null)"; then
echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
else
echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"