summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2017-02-06 21:07:38 +0100
committerNicolas Iooss2017-02-06 21:07:38 +0100
commitb32c15e7a25f46475b040e8862627ac53ec6062c (patch)
tree2a66688e2905619687a24b002548532ac6ffa83e /PKGBUILD
parent7e5c239cf77598a6df1c7312533bc63d4931414d (diff)
downloadaur-b32c15e7a25f46475b040e8862627ac53ec6062c.tar.gz
openssh-selinux: make tests' graceful dropout work
Fix last commit, with https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/openssh&id=9f0f14b2799ed54745f83dd797bb41c229e6592c
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1368df1fdc5e..3f52a5871781 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,14 +64,13 @@ build() {
check() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
- [[ -e /.arch-chroot ]] && return
- # Connectivity tests will fail under makechrootpkg since
- # it runs as nobody which has /bin/false as login shell.
+ # Tests require openssh to be already installed system-wide,
+ # also connectivity tests will fail under makechrootpkg since
+ # it runs as nobody which has /bin/false as login shell.
- [[ -e /usr/bin/scp ]] || return
- # Tests require openssh to be already installed system-wide.
-
- make tests
+ if [[ -e /usr/bin/scp && ! -e /.arch-chroot ]]; then
+ make tests
+ fi
}
package() {