summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian 'gonX' Jensen2021-11-13 18:01:50 +0100
committerSebastian 'gonX' Jensen2021-11-13 18:02:04 +0100
commit50629cfa882d36f909765a755f5a344a7a5d8f89 (patch)
treeecae910233cf8553c2823ee5845f840d6e9c77c0 /PKGBUILD
parent5a625ec1b2ea6b34f427e49d191e1934282a3944 (diff)
downloadaur-50629cfa882d36f909765a755f5a344a7a5d8f89.tar.gz
Don't strip symbols if strip isn't set in OPTIONS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaeb83b880c7..2e0d7e58c441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=OpenTabletDriver
_lpkgname=opentabletdriver
_spkgname=otd
pkgver=v0.5.3.1.r675.g35ae3e65
-pkgrel=6
+pkgrel=7
pkgdesc="A cross-platform open source tablet driver"
arch=('x86_64')
url="https://github.com/OpenTabletDriver/OpenTabletDriver"
@@ -44,10 +44,14 @@ build() {
PREFIX=$(git describe --long --tags | sed 's/-.*//;s/v//')
SUFFIX=$(git describe --long --tags | sed 's/^[^-]*-//;s/\([^-]*-g\)/r\1/;s/-/./g')
+ if check_option "strip" y; then
+ EXTRA_OPTIONS="/p:DebugType=None /p:DebugSymbols=false"
+ fi
+
./build.sh linux-x64 \
--version-suffix "$SUFFIX" \
/p:VersionPrefix="$PREFIX" \
- /p:DebugType=None /p:DebugSymbols=false
+ $EXTRA_OPTIONS
dotnet build OpenTabletDriver.Tools.udev \
--configuration Release \
@@ -67,7 +71,7 @@ package() {
install -do root "$pkgdir/usr/share/$_pkgname"
cd "$srcdir/$_pkgname/bin"
- for binary in *.dll *.json; do
+ for binary in *.dll *.json *.pdb; do
install -Dm 755 -o root "$binary" -t "$pkgdir/usr/share/$_pkgname"
done
cd "$srcdir"