summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian 'gonX' Jensen2021-10-12 04:17:37 +0200
committerSebastian 'gonX' Jensen2021-10-12 04:17:37 +0200
commit64295d7fed4409c02bc6bafd3995ef638659c9ed (patch)
treebf68cc27d007594e41b341eb7c881ff63f0904a0 /PKGBUILD
parent8160f4636c8c51de2a00896cdf5a9f0ec21d9ddf (diff)
downloadaur-64295d7fed4409c02bc6bafd3995ef638659c9ed.tar.gz
Don't build or package debug symbols
makepkg complains about references to $srcdir, this eliminates that. I'm open for reverting this commit if there's a good reason to
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc019b9c9d41..2d492b11cea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=OpenTabletDriver
_lpkgname=opentabletdriver
_spkgname=otd
pkgver=v0.5.3.1.r524.g17d1cad6
-pkgrel=2
+pkgrel=3
pkgdesc="A cross-platform open source tablet driver"
arch=('x86_64')
url="https://github.com/OpenTabletDriver/OpenTabletDriver"
@@ -52,7 +52,8 @@ build() {
--output "./$_pkgname/out" \
/p:VersionPrefix="$PREFIX" \
/p:SuppressNETCoreSdkPreviewMessage=true \
- /p:PublishTrimmed=false
+ /p:PublishTrimmed=false \
+ /p:DebugType=None /p:DebugSymbols=false
dotnet publish OpenTabletDriver.Console \
--configuration Release \
@@ -63,7 +64,8 @@ build() {
--version-suffix "$SUFFIX" \
/p:VersionPrefix="$PREFIX" \
/p:SuppressNETCoreSdkPreviewMessage=true \
- /p:PublishTrimmed=false
+ /p:PublishTrimmed=false \
+ /p:DebugType=None /p:DebugSymbols=false
dotnet publish OpenTabletDriver.UX.Gtk \
--configuration Release \
@@ -74,7 +76,8 @@ build() {
--version-suffix "$SUFFIX" \
/p:VersionPrefix="$PREFIX" \
/p:SuppressNETCoreSdkPreviewMessage=true \
- /p:PublishTrimmed=false
+ /p:PublishTrimmed=false \
+ /p:DebugType=None /p:DebugSymbols=false
dotnet build OpenTabletDriver.Tools.udev \
--configuration Release \
@@ -94,7 +97,7 @@ package() {
install -do root "$pkgdir/usr/share/$_pkgname"
cd "$srcdir/$_pkgname/$_pkgname/out"
- for binary in *.dll *.json *.pdb; do
+ for binary in *.dll *.json; do
install -Dm 755 -o root "$binary" -t "$pkgdir/usr/share/$_pkgname"
done
cd "$srcdir"