summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcyrant2019-09-04 01:09:02 +0400
committercyrant2019-09-04 01:09:02 +0400
commit5decbb21b72fa3da2b651c602d121d5f69a517a1 (patch)
treedd65f09532fd7d4cffddd011863dcab2e9501ae6 /PKGBUILD
parentb54ebb55e386dfcfaec0839af28321b40d6b9bb0 (diff)
downloadaur-5decbb21b72fa3da2b651c602d121d5f69a517a1.tar.gz
fix Qt 5.13 build error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11212a83ae4b..092b9b296e50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=opentoonz
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='This is software for producing a 2D animation.'
url='https://opentoonz.github.io'
license=('BSD')
@@ -10,8 +10,19 @@ arch=('x86_64')
conflicts=('opentoonz-git')
depends=('cblas' 'freeglut' 'glew' 'hicolor-icon-theme' 'libmypaint' 'qt5-multimedia' 'qt5-script' 'qt5-svg' 'sdl2' 'superlu')
makedepends=('boost' 'boost-libs' 'cmake' 'git' 'pkgconf' 'qt5-tools')
-source=("git+https://github.com/opentoonz/opentoonz.git#tag=v${pkgver}")
-md5sums=('SKIP')
+source=(
+ "git+https://github.com/opentoonz/opentoonz.git#tag=v${pkgver}"
+ "${pkgname}-build.patch::https://github.com/opentoonz/opentoonz/commit/adae1528d6f580d56b5499c97b30acfb84af4390.patch"
+)
+sha256sums=(
+ 'SKIP'
+ '9b8b4a68d3af0941ed83e655b68cf25037fedff24a53e3ae224b7f56337ab6f2'
+)
+
+prepare() {
+ cd "${pkgname}"
+ git apply "${srcdir}/${pkgname}-build.patch"
+}
build() {
cd "${srcdir}/${pkgname}/thirdparty/tiff-4.0.3/"