summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHanFox2021-02-17 09:18:10 +0000
committerHanFox2021-02-17 09:18:10 +0000
commit614619f68c997227f915b91a32fb41f58743870a (patch)
tree1ac11f81fd401d4afb3607ef1a11cca5ac0190cf /PKGBUILD
parent731b15d277470e93e609a781bcd7aa855d8555f8 (diff)
downloadaur-614619f68c997227f915b91a32fb41f58743870a.tar.gz
Updated to 0.40.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4a5b21ef8e5..04f0d17a4a0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Based on the 'aur/openttd-git' PKGBUILD by McModder <mcmodder@mcmodder.ru>
pkgname=openttd-jgrpp
-pkgver=0.40.1
+pkgver=0.40.2
pkgrel=1
pkgdesc="OpenTTD with JGR's patch pack."
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ license=('GPL')
makedepends=('tar' 'cmake')
depends=('libpng' 'sdl2' 'icu' 'fontconfig' 'lzo' 'hicolor-icon-theme' 'desktop-file-utils' 'xz' 'fluidsynth')
source=("https://github.com/JGRennison/OpenTTD-patches/archive/jgrpp-${pkgver}.tar.gz")
-sha256sums=('45c244b5cc48f1addb2ce578100ff8274f53cf3e879620812d8b4acd1217f131')
+sha256sums=('9065cd9ba1714f95774e09a3ea19769bdc10cb5597e77cf2ba45123195fd92df')
_dirname=OpenTTD-patches-jgrpp
@@ -21,12 +21,12 @@ build() {
-B build \
-S ${_dirname}-${pkgver} \
-DBINARY_NAME="${pkgname}" \
+ -DCMAKE_INSTALL_BINDIR="bin" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_DATADIR="share" \
-DCMAKE_INSTALL_DOCDIR="share/doc/${pkgname}" \
-DGLOBAL_DIR="/usr/share/${pkgname}" \
- -DPERSONAL_DIR=".${pkgname}" \
- ..
+ -DPERSONAL_DIR=".${pkgname}"
make -C build
}