summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAurifier2017-02-17 12:22:52 -0500
committerAurifier2017-02-17 12:22:52 -0500
commitc7afe1ae7d67749cdaaf5fdc379f11d31b916644 (patch)
tree11ec85bcce33dab9df159d7f407cf2e483ec7b2b /PKGBUILD
downloadaur-c7afe1ae7d67749cdaaf5fdc379f11d31b916644.tar.gz
Initial stab at getting a working package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beb6b8cbfc11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Drew Reed <reed.995@osu.edu>
+pkgname=openuru-moss
+pkgver=r41+.3e78d60a5282+
+pkgrel=1
+pkgdesc="MOSS is a UNIX-based server for the Myst Online: Uru Live client"
+arch=('i686' 'x86_64')
+url="openuru.org"
+license=('GPL')
+depends=('libpqxx'
+ 'postgresql')
+makedepends=()
+backup=()
+source=("$pkgname::hg+http://foundry.openuru.org/hg/MOSS"
+ "include_unistd.patch")
+md5sums=('SKIP'
+ '923b06d8c25265679bd35e532118f2ff')
+
+prepare() {
+ cd "$srcdir"
+ patch -p0 -i "include_unistd.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./bootstrap.sh
+ ./configure --prefix=/usr --enable-fast-download
+ make
+ cd "postgresql"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+ cd "postgresql"
+ make DESTDIR="$pkgdir/" install
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}