summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2024-03-06 19:17:46 -0300
committerDaniel Bermond2024-03-06 19:17:46 -0300
commitae1d113bb317db6e228af78549914c5ee1a18bfd (patch)
tree9809d512bc67b205ab48f52776ce75a94ecc9540 /PKGBUILD
parent1b95ab2b9ddc82ee231827652f077093f2a0bacf (diff)
downloadaur-ae1d113bb317db6e228af78549914c5ee1a18bfd.tar.gz
Update to version 2024.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 5 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61a4fdaa635b..0e9fb1daf09e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino
-pkgver=2023.3.0
-pkgrel=2
+pkgver=2024.0.0
+pkgrel=1
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications'
arch=('x86_64')
url='https://docs.openvinotoolkit.org/'
@@ -25,14 +25,11 @@ provides=('intel-openvino')
conflicts=('intel-openvino')
replaces=('intel-openvino')
options=('!emptydirs')
-_gnaver=03.05.00.2116 # GNA_VERSION in cmake/dependencies.cmake
source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
- "https://storage.openvinotoolkit.org/dependencies/gna/gna_${_gnaver}.zip"
'oneDNN-openvinotoolkit'::'git+https://github.com/openvinotoolkit/oneDNN.git'
'git+https://github.com/herumi/xbyak.git'
'git+https://github.com/madler/zlib.git'
'git+https://github.com/zeux/pugixml.git'
- 'git+https://github.com/opencv/ade.git'
'git+https://github.com/gflags/gflags.git'
'googletest-openvinotoolkit'::'git+https://github.com/openvinotoolkit/googletest.git'
'git+https://github.com/KhronosGroup/OpenCL-ICD-Loader.git'
@@ -52,12 +49,9 @@ source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
'git+https://github.com/openvinotoolkit/mlas.git'
'openvino.conf'
'setupvars.sh'
- '010-ade-disable-werror.patch'
- '015-openvino-disable-werror.patch'
+ '010-openvino-disable-werror.patch'
'020-openvino-use-protobuf-shared-libs.patch')
sha256sums=('SKIP'
- '960350567702bda17276ac4c060d7524fb7ce7ced785004bd861c81ff2bfe2c5'
- 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -81,9 +75,8 @@ sha256sums=('SKIP'
'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
- '502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0'
'1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e'
- '9e0f517320c4351489db5840658ffcf537716b23e88a02ee69380734a40ced21')
+ '17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -96,7 +89,6 @@ prepare() {
git -C openvino config --local submodule.thirdparty/xbyak.url "${srcdir}/xbyak"
git -C openvino config --local submodule.thirdparty/zlib/zlib.url "${srcdir}/zlib"
git -C openvino config --local submodule.thirdparty/pugixml.url "${srcdir}/pugixml"
- git -C openvino config --local submodule.thirdparty/ade.url "${srcdir}/ade"
git -C openvino config --local submodule.thirdparty/gflags/gflags.url "${srcdir}/gflags"
git -C openvino config --local submodule.thirdparty/gtest/gtest.url "${srcdir}/googletest-openvinotoolkit"
git -C openvino config --local submodule.thirdparty/ocl/icd_loader.url "${srcdir}/OpenCL-ICD-Loader"
@@ -116,15 +108,7 @@ prepare() {
git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/mlas.url "${srcdir}/mlas"
git -C openvino -c protocol.file.allow='always' submodule update
- mkdir -p openvino/temp
- cp -af "gna_${_gnaver}" openvino/temp
- printf '%s\n' "${source[1]}" > "openvino/temp/gna_${_gnaver}/ie_dependency.info"
-
- # ade gcc 13 fix
- git -C openvino/thirdparty/ade cherry-pick --no-commit 7cecc9138b89e1946e3e515727bb69b2ab119806
-
- patch -d openvino/thirdparty/ade -Np1 -i "${srcdir}/010-ade-disable-werror.patch"
- patch -d openvino -Np1 -i "${srcdir}/015-openvino-disable-werror.patch"
+ patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"
patch -d openvino -Np1 -i "${srcdir}/020-openvino-use-protobuf-shared-libs.patch"
}