summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Stinus2017-06-10 23:39:27 +0800
committerNicolas Stinus2017-06-15 00:27:22 +0800
commit05ef660c30980cbe5ac6e269957ca61c76dded41 (patch)
tree3f54bf29e3dbd1feae1440b769d7f2a9c16dc33b /PKGBUILD
parentcb2f45b0d97a838e64b9f8c96ac5aa4879ad68b1 (diff)
downloadaur-05ef660c30980cbe5ac6e269957ca61c76dded41.tar.gz
Pull master and adapt for new nordvpn infos command (requires python-pandas)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c038bb2fcd5a..9c2e5764533d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nicolas Stinus <nicolas.stinus@gmail.com>
pkgname=openvpn-nordvpn
-pkgver=0.1.7
+pkgver=0.1.9
pkgrel=1
pkgdesc="OpenVPN helper script for nordvpn.com"
arch=(any)
@@ -16,7 +16,8 @@ depends=('openvpn'
'coreutils'
'bc')
optdepends=('iputils: run ping and rank functions'
- 'vpnfailsafe-git: use instead of update-resolv-conf if available')
+ 'vpnfailsafe-git: use instead of update-resolv-conf if available'
+ 'python-pandas: run nordvpn infos command')
makedepends=('coreutils' 'pandoc')
provides=('nordvpn')
source=("git+https://github.com/nstinus/nordvpn.git#branch=${NORDVPN_BRANCH:-master}")
@@ -40,4 +41,9 @@ build() {
package() {
install -D -m 644 nordvpn.8.gz $pkgdir/usr/share/man/man8/nordvpn.8.gz
install -D -m 755 nordvpn/nordvpn $pkgdir/usr/bin/nordvpn
+ if [ -f nordvpn/servers.py ]
+ then
+ install -D -m 644 nordvpn/servers.py $pkgdir/etc/openvpn/client/nordvpn/servers.py
+ chmod 750 $pkgdir/etc/openvpn/client $pkgdir/etc/openvpn/client/nordvpn
+ fi
}