summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Stinus2017-06-02 21:38:58 +0800
committerNicolas Stinus2017-06-02 21:41:56 +0800
commit7b46eabf1baa81f4596c7f7469a1856eb74fab9d (patch)
treea65e01aa7cba7916623a8bc21fa101f058f3b6c7 /PKGBUILD
parent3ee48d7ad679d38b1eccd290e24af940df2072f8 (diff)
downloadaur-7b46eabf1baa81f4596c7f7469a1856eb74fab9d.tar.gz
Use master branch and get version from upstream tag (reset to v0.1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5e63e854b21..e0de562facb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
# Maintainer: Nicolas Stinus <nicolas.stinus@gmail.com>
pkgname=openvpn-nordvpn
-pkgver=17.6.1
-pkgrel=12
+pkgver=0.1.1
+pkgrel=1
pkgdesc="OpenVPN helper script for nordvpn.com"
arch=(any)
url="https://github.com/nstinus/nordvpn"
license=('MIT')
-depends=('openvpn' 'systemd' 'openvpn-update-resolv-conf-git' 'curl' 'unzip' 'coreutils')
+depends=('openvpn'
+ 'systemd'
+ 'openvpn-update-resolv-conf-git'
+ 'curl'
+ 'unzip'
+ 'coreutils')
optdepends=('iputils: run ping and rank functions'
'vpnfailsafe-git: use instead of update-resolv-conf if available')
makedepends=('coreutils')
provides=('nordvpn')
-source=('git+https://github.com/nstinus/nordvpn.git#commit=2cff124')
+source=('git+https://github.com/nstinus/nordvpn.git#branch=master')
sha1sums=('SKIP')
install=${pkgname}.install
+pkgver() {
+ git --git-dir $(pwd)/nordvpn/.git describe --always --long --match "v?.?" \
+ | sed 's/-/./' \
+ | cut -d '-' -f 1 \
+ | sed 's/v//'
+}
+
package() {
install -D -m 755 nordvpn/nordvpn $pkgdir/usr/bin/nordvpn
}