summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPete Alexandrou2017-05-07 16:24:01 +0800
committerPete Alexandrou2017-05-07 16:24:01 +0800
commit45295d25485489f6b2e44c1bed4ab80be1b42174 (patch)
treef248d48e390eb1acaf22534ce1fe9134efed87c2 /PKGBUILD
parent6431bee2815fd4018a8705a9ef4ad150c5882b1a (diff)
downloadaur-45295d25485489f6b2e44c1bed4ab80be1b42174.tar.gz
small tweaks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 6 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 915f7515527b..7861f9f409fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=openvpn-xor-git
_pkgname=openvpn
pkgver=2.4.1
-pkgrel=3
+pkgrel=4
pkgdesc='OpenVPN with XOR patch to bypass DPI monitoring in places like China (also known as OpenVPN stealth/scramble mode)'
arch=('i686' 'x86_64')
url='https://github.com/openvpn/openvpn'
@@ -52,20 +52,6 @@ build() {
autoreconf -vi
- # ./configure \
- # --build=x86_64 \
- # --host=x86_64 \
- # --prefix=/usr \
- # --enable-crypto \
- # --enable-iproute2 \
- # --enable-password-save \
- # --enable-pkcs11 \
- # --enable-plugins \
- # --enable-ssl \
- # --enable-systemd \
- # --sbindir=/usr/bin \
- # --mandir=/usr/share/man
-
./configure \
--prefix=/usr \
--sbindir=/usr/bin \
@@ -108,7 +94,11 @@ package() {
esac
done
+ # enable scheduling priority changes (nice)
+ sed -i '14s/$/ CAP_SYS_NICE/' ${pkgdir}/usr/lib/systemd/system/${_pkgname}-client@.service
+ sed -i '15s/$/ CAP_SYS_NICE/' ${pkgdir}/usr/lib/systemd/system/${_pkgname}-server@.service
+
# Install systemd files
install -D -m0644 distro/systemd/${_pkgname}-client@.service ${pkgdir}/usr/lib/systemd/system/${_pkgname}-client@.service
install -D -m0644 distro/systemd/${_pkgname}-server@.service ${pkgdir}/usr/lib/systemd/system/${_pkgname}-server@.service
- }
+}