summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Maurer2024-03-19 19:07:10 +0100
committerFabian Maurer2024-03-19 19:07:10 +0100
commitd54c13fa15b8d311ab06a3aa3aeac66d9da878fd (patch)
tree18e66c4ef9ce2db28e6d6fd402b0a6abfe5c929e /PKGBUILD
parentdb1c09b020bf68caffeafcec92c2df3422607f7a (diff)
downloadaur-openwatcom-v2.tar.gz
Use permalink and fix permissons
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f29a2891a63f..df60c72d77fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
-# Mantainer: Jens Staal <staal1978@gmail.com>
+# Maintainer: Fabian Maurer <dark.shadow4@web.de>
+# Contributor: Jens Staal <staal1978@gmail.com>
# Contributor : ackalker
pkgname=openwatcom-v2
-pkgver=2.0
-pkgrel=8
+pkgver=2.0_2024_03_01
+pkgrel=1
pkgdesc="The Open Watcom Fortran/C/C++ compiler, binary distribution -V2 fork"
arch=('x86_64')
#url="http://www.openwatcom.org"
url="https://github.com/open-watcom"
license=('custom:OWPL-1')
source=(
-'https://github.com/open-watcom/open-watcom-v2/releases/download/Last-CI-build/ow-snapshot.tar.xz'
+'https://github.com/open-watcom/open-watcom-v2/releases/download/2024-03-01-Build/ow-snapshot.tar.xz'
'owsetenv.sh'
)
noextract=('ow-snapshot.tar.gz')
-#md5sums change frequently since it is a snapshot. If it fails, download manually and check md5sum
-md5sums=('SKIP'
+md5sums=('bfd38da3e929655048fc8c0dd5077aae'
'2abd462742068d76a5cf1753b128ac94')
options=(!strip)
@@ -41,4 +41,7 @@ package() {
cd $pkgdir/opt/watcom/binl
ln -s /usr/bin/true ranlib
ln -s wlib ar
+
+ # fix ownership
+ chown -R root:root $pkgdir/opt/watcom/
}